summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-09-07 21:38:10 -0400
committerTony Lambiris2021-09-07 21:38:10 -0400
commit38d0962561691ce269d396a353034aea07c8e27e (patch)
treefbc9ff3dae772341103c92f9c99c59e77c39cb3e
parent39db56ac0a0442282a8879f32b9a2f0a54217c73 (diff)
downloadaur-38d0962561691ce269d396a353034aea07c8e27e.tar.gz
Version bump, remove old patch file.
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
-rw-r--r--fix-compile-warnings-treated-as-errors-for-gcc9.patch59
4 files changed, 17 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e597a340acc..f77103f57414 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocksdb-static
pkgdesc = Embedded key-value store for fast storage (static library)
- pkgver = 6.6.4
+ pkgver = 6.22.1
pkgrel = 1
url = http://rocksdb.org
arch = i686
@@ -13,8 +13,7 @@ pkgbase = rocksdb-static
depends = lz4
depends = snappy
depends = gcc-libs
- source = https://github.com/facebook/rocksdb/archive/v6.6.4.tar.gz
- sha256sums = feab859ee355fbe7beffd7085904b63f560417f450f83cc34310e6dadff936f6
+ source = https://github.com/facebook/rocksdb/archive/v6.22.1.tar.gz
+ sha256sums = 2df8f34a44eda182e22cf84dee7a14f17f55d305ff79c06fb3cd1e5f8831e00d
pkgname = rocksdb-static
-
diff --git a/.gitignore b/.gitignore
index 6d9731b79380..60793a475d53 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
src
pkg
v*.tar.gz
-*pkg.tar.xz
+*.pkg.tar.*
tags
diff --git a/PKGBUILD b/PKGBUILD
index 70e631fdbcd9..7e2a383f44a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony <tony@libpcap.net>
pkgname=rocksdb-static
-pkgver=6.6.4
+pkgver=6.22.1
pkgrel=1
pkgdesc='Embedded key-value store for fast storage (static library)'
arch=(i686 x86_64)
@@ -10,27 +10,27 @@ license=('Apache')
depends=('gperftools' 'zlib' 'bzip2' 'lz4' 'snappy' 'gcc-libs')
checkdepends=('python2')
source=("https://github.com/facebook/rocksdb/archive/v${pkgver}.tar.gz")
-sha256sums=('feab859ee355fbe7beffd7085904b63f560417f450f83cc34310e6dadff936f6')
+sha256sums=('2df8f34a44eda182e22cf84dee7a14f17f55d305ff79c06fb3cd1e5f8831e00d')
prepare() {
- cd "${srcdir}/rocksdb-${pkgver}"
+ cd "${srcdir}/rocksdb-${pkgver}"
- sed -e 's/\bpython\b/python2/' -i Makefile
- if [ "$CARCH" == "armv6h" ]; then
- sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
- fi
+ sed -e 's/\bpython\b/python2/' -i Makefile
+ if [ "$CARCH" == "armv6h" ]; then
+ sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
+ fi
}
build() {
- cd "${srcdir}/rocksdb-${pkgver}"
+ cd "${srcdir}/rocksdb-${pkgver}"
- env USE_RTTI=1 make static_lib
+ env USE_RTTI=1 make static_lib
}
package() {
- cd "${srcdir}/rocksdb-${pkgver}"
+ cd "${srcdir}/rocksdb-${pkgver}"
- install -Dm755 librocksdb.a "${pkgdir}"/usr/lib/librocksdb.a
- install -Dm644 LICENSE.Apache "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.Apache"
- install -Dm644 LICENSE.leveldb "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.leveldb"
+ install -Dm755 librocksdb.a "${pkgdir}"/usr/lib/librocksdb.a
+ install -Dm644 LICENSE.Apache "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.Apache"
+ install -Dm644 LICENSE.leveldb "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.leveldb"
}
diff --git a/fix-compile-warnings-treated-as-errors-for-gcc9.patch b/fix-compile-warnings-treated-as-errors-for-gcc9.patch
deleted file mode 100644
index 2bdbcd4a6bed..000000000000
--- a/fix-compile-warnings-treated-as-errors-for-gcc9.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff --git a/db/internal_stats.h b/db/internal_stats.h
-index 20fb07f485..ebe90d574d 100644
---- a/db/internal_stats.h
-+++ b/db/internal_stats.h
-@@ -237,6 +237,28 @@ class InternalStats {
- }
- }
-
-+ CompactionStats& operator=(const CompactionStats& c) {
-+ micros = c.micros;
-+ cpu_micros = c.cpu_micros;
-+ bytes_read_non_output_levels = c.bytes_read_non_output_levels;
-+ bytes_read_output_level = c.bytes_read_output_level;
-+ bytes_written = c.bytes_written;
-+ bytes_moved = c.bytes_moved;
-+ num_input_files_in_non_output_levels =
-+ c.num_input_files_in_non_output_levels;
-+ num_input_files_in_output_level = c.num_input_files_in_output_level;
-+ num_output_files = c.num_output_files;
-+ num_input_records = c.num_input_records;
-+ num_dropped_records = c.num_dropped_records;
-+ count = c.count;
-+
-+ int num_of_reasons = static_cast<int>(CompactionReason::kNumOfReasons);
-+ for (int i = 0; i < num_of_reasons; i++) {
-+ counts[i] = c.counts[i];
-+ }
-+ return *this;
-+ }
-+
- void Clear() {
- this->micros = 0;
- this->cpu_micros = 0;
-diff --git a/db/version_edit.h b/db/version_edit.h
-index e1857b37fc..4a93db34e1 100644
---- a/db/version_edit.h
-+++ b/db/version_edit.h
-@@ -52,6 +52,8 @@ struct FileDescriptor {
- smallest_seqno(_smallest_seqno),
- largest_seqno(_largest_seqno) {}
-
-+ FileDescriptor(const FileDescriptor& fd) { *this=fd; }
-+
- FileDescriptor& operator=(const FileDescriptor& fd) {
- table_reader = fd.table_reader;
- packed_number_and_path_id = fd.packed_number_and_path_id;
-diff --git a/utilities/persistent_cache/persistent_cache_util.h b/utilities/persistent_cache/persistent_cache_util.h
-index 214bb5875d..254c038f98 100644
---- a/utilities/persistent_cache/persistent_cache_util.h
-+++ b/utilities/persistent_cache/persistent_cache_util.h
-@@ -48,7 +48,7 @@ class BoundedQueue {
- T t = std::move(q_.front());
- size_ -= t.Size();
- q_.pop_front();
-- return std::move(t);
-+ return t;
- }
-
- size_t Size() const {