summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-05-13 11:23:30 +0200
committerTorsten Keßler2021-05-13 11:23:30 +0200
commit03ea9fe7666f5f1fcb3977df7f644e36eaee0438 (patch)
tree20836a4052cd645f25635416b16db5e7a5421313
parent1b1bc21d44a9924dcdceed9915c9a6144aaa322d (diff)
downloadaur-03ea9fe7666f5f1fcb3977df7f644e36eaee0438.tar.gz
upgpkg: rocm-bandwidth-test 4.2.0-1
upstream release new release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 13 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d5a1dcd91c6..d7b2d69fe158 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocm-bandwidth-test
pkgdesc = Bandwidth test for ROCm
- pkgver = 4.0.0
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/rocm_bandwidth_test
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = rocm-bandwidth-test
depends = hsa-rocr
options = !staticlibs
options = strip
- source = rocm-bandwidth-test-4.0.0.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-4.0.0.tar.gz
- sha256sums = bde2aa743979eac195dd13ec8d0fcb7da183fff489da32c28b872eed7f6681b3
+ source = rocm-bandwidth-test-4.2.0.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-4.2.0.tar.gz
+ sha256sums = d268365e3bb8031c1201c05e705074d1fd794d236843f80064855cf31e4412f5
pkgname = rocm-bandwidth-test
diff --git a/PKGBUILD b/PKGBUILD
index 062608e97bb4..43c6e2f642f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
+# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=rocm-bandwidth-test
-pkgver=4.0.0
+pkgver=4.2.0
pkgrel=1
pkgdesc="Bandwidth test for ROCm"
arch=('x86_64')
@@ -10,26 +11,16 @@ depends=('hsa-rocr')
makedepends=('cmake')
options=(!staticlibs strip)
source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-$pkgver.tar.gz")
-sha256sums=('bde2aa743979eac195dd13ec8d0fcb7da183fff489da32c28b872eed7f6681b3')
+sha256sums=('d268365e3bb8031c1201c05e705074d1fd794d236843f80064855cf31e4412f5')
+_dirname="$(basename "$url")-$(basename "${source[0]}" .tar.gz)"
build() {
- mkdir -p "$srcdir/build"
- cd "$srcdir/build"
-
- cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocm_bandwidth_test \
- "$srcdir/rocm_bandwidth_test-rocm-$pkgver"
- make
+ cmake -Wno-dev -B build \
+ -S "$_dirname" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm
+ make -C build
}
package() {
- cd "$srcdir/build"
-
- make DESTDIR="$pkgdir" install
-
- # add links
- install -d "$pkgdir/usr/bin"
- local _fn
- for _fn in rocm-bandwidth-test; do
- ln -s "/opt/rocm/rocm_bandwidth_test/bin/$_fn" "$pkgdir/usr/bin/$_fn"
- done
+ DESTDIR="$pkgdir" make -C build install
}