summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-08-08 15:46:09 +0200
committerTorsten Keßler2021-08-08 15:46:09 +0200
commit6e6214459d009070be8660364561bde7189c9455 (patch)
tree3f7611820412a4ce00b6e809eb34ad26f75c818b
parent03ea9fe7666f5f1fcb3977df7f644e36eaee0438 (diff)
downloadaur-6e6214459d009070be8660364561bde7189c9455.tar.gz
upgpkg: rocm-bandwidth-test 4.3.0-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7b2d69fe158..9247147ca8fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocm-bandwidth-test
pkgdesc = Bandwidth test for ROCm
- pkgver = 4.2.0
+ pkgver = 4.3.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/rocm_bandwidth_test
arch = x86_64
@@ -9,7 +9,9 @@ pkgbase = rocm-bandwidth-test
depends = hsa-rocr
options = !staticlibs
options = strip
- source = rocm-bandwidth-test-4.2.0.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-4.2.0.tar.gz
- sha256sums = d268365e3bb8031c1201c05e705074d1fd794d236843f80064855cf31e4412f5
+ source = rocm-bandwidth-test-4.3.0.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-4.3.0.tar.gz
+ source = delete_local_array.patch::https://patch-diff.githubusercontent.com/raw/RadeonOpenCompute/rocm_bandwidth_test/pull/74.patch
+ sha256sums = c6eb406cd2836af61dd5987f6b761340a1be20f66a9325f480423d10b9d3ec1b
+ sha256sums = c13fcff87232d443061a9fc9d0aa151d5fad4921ea7fb98e189ace17a345106d
pkgname = rocm-bandwidth-test
diff --git a/PKGBUILD b/PKGBUILD
index 43c6e2f642f6..e5607a417141 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=rocm-bandwidth-test
-pkgver=4.2.0
+pkgver=4.3.0
pkgrel=1
pkgdesc="Bandwidth test for ROCm"
arch=('x86_64')
@@ -10,10 +10,17 @@ license=('custom:NCSAOSL')
depends=('hsa-rocr')
makedepends=('cmake')
options=(!staticlibs strip)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-$pkgver.tar.gz")
-sha256sums=('d268365e3bb8031c1201c05e705074d1fd794d236843f80064855cf31e4412f5')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-$pkgver.tar.gz"
+ 'delete_local_array.patch::https://patch-diff.githubusercontent.com/raw/RadeonOpenCompute/rocm_bandwidth_test/pull/74.patch')
+sha256sums=('c6eb406cd2836af61dd5987f6b761340a1be20f66a9325f480423d10b9d3ec1b'
+ 'c13fcff87232d443061a9fc9d0aa151d5fad4921ea7fb98e189ace17a345106d')
_dirname="$(basename "$url")-$(basename "${source[0]}" .tar.gz)"
+prepare() {
+ cd "$_dirname"
+ patch -Np1 -i "$srcdir/delete_local_array.patch"
+}
+
build() {
cmake -Wno-dev -B build \
-S "$_dirname" \