summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2023-07-18 09:04:02 +0200
committerTorsten Keßler2023-07-18 09:04:02 +0200
commitedacb87a12e8eac4a1a61c67f1bdd057836908b1 (patch)
tree23bdcbb231ac008b1209ef8939a636c57d68407d
parent80873aa9809ce435cb522816bc03d63b36ee6f82 (diff)
downloadaur-edacb87a12e8eac4a1a61c67f1bdd057836908b1.tar.gz
upgpkg: rocm-bandwidth-test 5.6.0-1
Add patch to silence warnings (-Werror)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--rocm-bandwidth-test-hsa-include.patch74
3 files changed, 89 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6304ebf8c2e4..9411b6c4d402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = rocm-bandwidth-test
pkgdesc = Bandwidth test for ROCm
- pkgver = 5.4.1
+ pkgver = 5.6.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/rocm_bandwidth_test
arch = x86_64
license = custom:NCSAOSL
makedepends = cmake
depends = hsa-rocr
- source = rocm-bandwidth-test-5.4.1.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-5.4.1.tar.gz
- sha256sums = fe163900117bf3ab094fbe87bc1a48e8c7a8141488406efc2815b3d27b69d277
+ source = rocm-bandwidth-test-5.6.0.tar.gz::https://github.com/RadeonOpenCompute/rocm_bandwidth_test/archive/rocm-5.6.0.tar.gz
+ source = rocm-bandwidth-test-hsa-include.patch
+ sha256sums = ae2f7263a21a3a650068f43e3112b2b765eea80a5af2297572f850c77f83c85e
+ sha256sums = 8c3be607d36fb5aa01f770c244c5d4088dffddf879a21a9e0ac80d6dbcd2dbdf
pkgname = rocm-bandwidth-test
diff --git a/PKGBUILD b/PKGBUILD
index 0f42a7d4f638..ed2540be64bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <tpkessler at archlinux dot org>
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=rocm-bandwidth-test
-pkgver=5.4.1
+pkgver=5.6.0
pkgrel=1
pkgdesc="Bandwidth test for ROCm"
arch=('x86_64')
@@ -9,10 +9,17 @@ url="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
license=('custom:NCSAOSL')
depends=('hsa-rocr')
makedepends=('cmake')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/rocm-$pkgver.tar.gz")
-sha256sums=('fe163900117bf3ab094fbe87bc1a48e8c7a8141488406efc2815b3d27b69d277')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/rocm-$pkgver.tar.gz"
+ "$pkgname-hsa-include.patch")
+sha256sums=('ae2f7263a21a3a650068f43e3112b2b765eea80a5af2297572f850c77f83c85e'
+ '8c3be607d36fb5aa01f770c244c5d4088dffddf879a21a9e0ac80d6dbcd2dbdf')
_dirname="$(basename "$url")-$(basename "${source[0]}" .tar.gz)"
+prepare() {
+ cd "$_dirname"
+ patch -Np1 -i "$srcdir/$pkgname-hsa-include.patch"
+}
+
build() {
cmake \
-Wno-dev \
diff --git a/rocm-bandwidth-test-hsa-include.patch b/rocm-bandwidth-test-hsa-include.patch
new file mode 100644
index 000000000000..c4b5c3fccc47
--- /dev/null
+++ b/rocm-bandwidth-test-hsa-include.patch
@@ -0,0 +1,74 @@
+From a58f9fd4cb5d1120b9ce58c912ca87fa14720f73 Mon Sep 17 00:00:00 2001
+From: pppig236 <weikaik@umich.edu>
+Date: Tue, 2 May 2023 15:19:52 -0400
+Subject: [PATCH] fix include for rocm 5.5.0
+
+---
+ base_test.hpp | 8 +-------
+ common.hpp | 11 ++---------
+ rocm_bandwidth_test.hpp | 8 +-------
+ 3 files changed, 4 insertions(+), 23 deletions(-)
+
+diff --git a/base_test.hpp b/base_test.hpp
+index 3e79de1..af99a85 100755
+--- a/base_test.hpp
++++ b/base_test.hpp
+@@ -42,14 +42,8 @@
+
+ #ifndef ROC_BANDWIDTH_TEST_BASE_H_
+ #define ROC_BANDWIDTH_TEST_BASE_H_
+-#if(defined(RBT_HSA_VERSION_FLAT) && ((RBT_HSA_VERSION_FLAT) < RBT_HSA_VERSION_FILEREORG))
+-// Hsa package with out file reorganization
+-// This is for backward compatibility and will be deprecated from future release
+-#include "hsa.h"
+-#else
+ // Hsa package with file reorganization
+-#include "hsa/hsa.h"
+-#endif
++#include <hsa/hsa.h>
+ #include <iostream>
+ #include <string>
+ #include <vector>
+diff --git a/common.hpp b/common.hpp
+index d2933a0..3c4858f 100755
+--- a/common.hpp
++++ b/common.hpp
+@@ -48,16 +48,9 @@
+ #include <vector>
+ #include <cmath>
+ #include <stdio.h>
+-#if(defined(RBT_HSA_VERSION_FLAT) && ((RBT_HSA_VERSION_FLAT) < RBT_HSA_VERSION_FILEREORG))
+-// Hsa package with out file reorganization
+-// This is for backward compatibility and will be deprecated from future release
+-#include "hsa.h"
+-#include "hsa_ext_amd.h"
+-#else
+ // Hsa package with file reorganization
+-#include "hsa/hsa.h"
+-#include "hsa/hsa_ext_amd.h"
+-#endif
++#include <hsa/hsa.h>
++#include <hsa/hsa_ext_amd.h>
+
+ using namespace std;
+
+diff --git a/rocm_bandwidth_test.hpp b/rocm_bandwidth_test.hpp
+index f7eb338..b8550a7 100755
+--- a/rocm_bandwidth_test.hpp
++++ b/rocm_bandwidth_test.hpp
+@@ -43,14 +43,8 @@
+ #ifndef __ROC_BANDWIDTH_TEST_H__
+ #define __ROC_BANDWIDTH_TEST_H__
+
+-#if(defined(RBT_HSA_VERSION_FLAT) && ((RBT_HSA_VERSION_FLAT) < RBT_HSA_VERSION_FILEREORG))
+-// Hsa package with out file reorganization
+-// This is for backward compatibility and will be deprecated from future release
+-#include "hsa.h"
+-#else
+ // Hsa package with file reorganization
+-#include "hsa/hsa.h"
+-#endif
++#include <hsa/hsa.h>
+ #include "base_test.hpp"
+ #include "common.hpp"
+