summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2019-11-28 17:48:16 +0100
committernaetherm2019-11-28 17:48:16 +0100
commit9a6c457f758cfdc3e824b33f23a7e12b6397b4a1 (patch)
treece3ccbd2aff8c5cd0911243a9cbc515d0274e2e5
downloadaur-9a6c457f758cfdc3e824b33f23a7e12b6397b4a1.tar.gz
Initial commit for 2.10.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a8aac465215
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rocm-cmake
+ pkgdesc = cmake modules for common build tasks needed for the ROCM software stack
+ pkgver = 2.10.0
+ pkgrel = 1
+ url = https://github.com/RadeonOpenCompute/rocm-cmake
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ conflicts = rocm-cmake-git
+ source = https://github.com/RadeonOpenCompute/rocm-cmake/archive/roc-2.10.0.tar.gz
+ sha256sums = 4ff9db5cf1cee1f4af96d0240e1a3068b39111b559808e6437f3748f86673181
+
+pkgname = rocm-cmake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3cff95f5973
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Original build: fermyon <antifermion@protonmail.com>
+# Maintainer: Markus Näther <naetherm@cs.uni-freiburg.de>
+pkgname=rocm-cmake
+pkgver=2.10.0
+pkgrel=1
+pkgdesc="cmake modules for common build tasks needed for the ROCM software stack"
+arch=(x86_64)
+url="https://github.com/RadeonOpenCompute/rocm-cmake"
+license=(MIT)
+makedepends=(git cmake)
+conflicts=(rocm-cmake-git)
+source=("https://github.com/RadeonOpenCompute/rocm-cmake/archive/roc-$pkgver.tar.gz")
+sha256sums=('4ff9db5cf1cee1f4af96d0240e1a3068b39111b559808e6437f3748f86673181')
+
+build() {
+ cd "$srcdir/${pkgname}-roc-${pkgver}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm" ..
+}
+
+package() {
+ cd "$srcdir/${pkgname}-roc-${pkgver}/build"
+ cmake --build . --target install
+}