summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn2022-04-09 00:44:51 -0700
committerGitHub2022-04-09 09:44:51 +0200
commit601dd05f4ff7ee294012bdae5bcfa7c2ff23743f (patch)
treed89d644464f2ab4e592da743467b7f4dfa737e07
parent550e015e4a51278722c4db755b1da4d350080d62 (diff)
downloadaur-601dd05f4ff7ee294012bdae5bcfa7c2ff23743f.tar.gz
Re-enable support for gfx800 (#742)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--enable-gfx800.patch16
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 464e668b74bd..bbae70ed16e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rocm-opencl-runtime
pkgdesc = Radeon Open Compute - OpenCL runtime
pkgver = 5.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime
arch = x86_64
license = MIT
@@ -16,7 +16,9 @@ pkgbase = rocm-opencl-runtime
conflicts = opencl-amdgpu-pro-pal
source = rocm-opencl-runtime-5.1.0.tar.gz::https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/archive/rocm-5.1.0.tar.gz
source = rocm-opencl-runtime-rocclr-5.1.0.tar.gz::https://github.com/ROCm-Developer-Tools/ROCclr/archive/rocm-5.1.0.tar.gz
+ source = enable-gfx800.patch
sha256sums = 362d81303048cf7ed5d2f69fb65ed65425bc3da4734fff83e3b8fbdda51b0927
sha256sums = f4f265604b534795a275af902b2c814f416434d9c9e16db81b3ed5d062187dfa
+ sha256sums = b186dd4a604d6e8a2c94ba6569638aaa8066558d764aa0d9cf76f998724ed90a
pkgname = rocm-opencl-runtime
diff --git a/PKGBUILD b/PKGBUILD
index 3c3125a72943..af246fe7b7a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rocm-opencl-runtime
pkgver=5.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Radeon Open Compute - OpenCL runtime'
arch=('x86_64')
url='https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime'
@@ -15,12 +15,21 @@ provides=('opencl-driver')
conflicts=('opencl-amdgpu-pro-pal')
_rocclr='https://github.com/ROCm-Developer-Tools/ROCclr'
source=("$pkgname-$pkgver.tar.gz::$url/archive/rocm-$pkgver.tar.gz"
- "$pkgname-rocclr-$pkgver.tar.gz::$_rocclr/archive/rocm-$pkgver.tar.gz")
+ "$pkgname-rocclr-$pkgver.tar.gz::$_rocclr/archive/rocm-$pkgver.tar.gz"
+ "enable-gfx800.patch")
sha256sums=('362d81303048cf7ed5d2f69fb65ed65425bc3da4734fff83e3b8fbdda51b0927'
- 'f4f265604b534795a275af902b2c814f416434d9c9e16db81b3ed5d062187dfa')
+ 'f4f265604b534795a275af902b2c814f416434d9c9e16db81b3ed5d062187dfa'
+ 'b186dd4a604d6e8a2c94ba6569638aaa8066558d764aa0d9cf76f998724ed90a')
_dirname="$(basename "$url")-$(basename "${source[0]}" .tar.gz)"
_rocclr_dir="$(basename "$_rocclr")-$(basename "${source[1]}" .tar.gz)"
+prepare() {
+ #From xuhuisheng
+ #at https://github.com/RadeonOpenCompute/ROCm/issues/1659#issuecomment-1041026624
+ cd "$_rocclr_dir"
+ patch -p1 -i "$srcdir/enable-gfx800.patch"
+}
+
build() {
cmake -Wno-dev -B build-rocclr \
-S "$_rocclr_dir" \
diff --git a/enable-gfx800.patch b/enable-gfx800.patch
new file mode 100644
index 000000000000..29482340295e
--- /dev/null
+++ b/enable-gfx800.patch
@@ -0,0 +1,16 @@
+#From xuhuisheng
+#at https://github.com/RadeonOpenCompute/ROCm/issues/1659#issuecomment-1041026624
+
+diff --git a/utils/flags.hpp b/utils/flags.hpp
+index 8f0228cc..2eaa47c5 100644
+--- a/utils/flags.hpp
++++ b/utils/flags.hpp
+@@ -245,7 +245,7 @@ release(bool, ROC_SYSTEM_SCOPE_SIGNAL, true, \
+ "Enable system scope for signals (uses interrupts).") \
+ release(bool, ROC_SKIP_COPY_SYNC, false, \
+ "Skips copy syncs if runtime can predict the same engine.") \
+-release(bool, ROC_ENABLE_PRE_VEGA, false, \
++release(bool, ROC_ENABLE_PRE_VEGA, true, \
+ "Enable support of pre-vega ASICs in ROCm path") \
+ release(bool, HIP_FORCE_QUEUE_PROFILING, false, \
+ "Force command queue profiling by default") \