summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2020-01-10 13:18:38 +0100
committernaetherm2020-01-10 13:18:38 +0100
commit590a949e9db9994ca65f595d352462ab0d38a1eb (patch)
tree532f1767ad2731e3dd1fe17c281f21aad7a11818
parent6eb80c6878334f74101d849628f3123b86e23a6f (diff)
downloadaur-590a949e9db9994ca65f595d352462ab0d38a1eb.tar.gz
Updated to version 3.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--python2_fix.patch9
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 369bc86657bd..bbd27083f7aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = rocm-smi
pkgdesc = Utility to manage and monitor AMDGPU / ROCm systems.
- pkgver = 2.9.0
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/ROC-smi/
arch = any
license = MIT
depends = python
- source = rocm-smi-2.9.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-2.9.0.tar.gz
- sha256sums = a7f97a5c23c54c08b0da421f7f6451241087d78ddb9722e79de5050c23f47dc3
+ source = rocm-smi-3.0.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-3.0.0.tar.gz
+ source = python2_fix.patch
+ sha256sums = b35cb654c3a794586ff60cf226884239e19cb91c0a5c2cb1d4e7b1be1cb845b2
+ sha256sums = SKIP
pkgname = rocm-smi
diff --git a/PKGBUILD b/PKGBUILD
index 8bb695c1a079..a87ad5ed7694 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rigo Reddig <rigo.reddig@gmail.com>
pkgname=rocm-smi
-pkgver=2.9.0
+pkgver=3.0.0
pkgrel=1
_filename=roc-${pkgver}.tar.gz
pkgdesc="Utility to manage and monitor AMDGPU / ROCm systems."
@@ -8,8 +8,19 @@ arch=('any')
url="https://github.com/RadeonOpenCompute/ROC-smi/"
license=('MIT')
depends=(python)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/${_filename}")
-sha256sums=('a7f97a5c23c54c08b0da421f7f6451241087d78ddb9722e79de5050c23f47dc3')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/${_filename}"
+ "python2_fix.patch"
+)
+sha256sums=(
+ 'b35cb654c3a794586ff60cf226884239e19cb91c0a5c2cb1d4e7b1be1cb845b2'
+ 'SKIP'
+)
+
+prepare() {
+ cd "${srcdir}/ROC-smi-roc-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/python2_fix.patch"
+}
package() {
diff --git a/python2_fix.patch b/python2_fix.patch
new file mode 100644
index 000000000000..367d318443b3
--- /dev/null
+++ b/python2_fix.patch
@@ -0,0 +1,9 @@
+diff --unified --recursive --text ROC-smi-roc-3.0.0/rocm_smi.py ROC-smi-roc-3.0.0/rocm_smi.py
+--- ROC-smi-roc-3.0.0/rocm_smi.py 2019-12-03 20:15:25.000000000 +0100
++++ ROC-smi-roc-3.0.0/rocm_smi.py 2020-01-10 08:08:23.885794471 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2.7
+ """ ROCm-SMI (System Management Interface) Tool
+
+ This tool provides a user-friendly interface for manipulating