summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrigred2019-02-05 15:00:46 +0200
committerrigred2019-02-05 15:00:46 +0200
commit75b7c35b4c8f0b8cd1fee8239a6eb8aa98723c03 (patch)
tree4217d991d082a2a19ea1bcd9df68e5d6d1eae0d7
parent356de4b4d5d9c3d398cac972e33570e5a88c7eb7 (diff)
downloadaur-75b7c35b4c8f0b8cd1fee8239a6eb8aa98723c03.tar.gz
rocm-smi 2.1.0
New Release with several new additions, see the upstream git for details: https://github.com/RadeonOpenCompute/ROC-smi/ Signed-off-by: Rigo Reddig <rigo.reddig@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--temporary-fixpoweroverdrive.patch56
3 files changed, 8 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e9c9131e50f..0ac55ee2a286 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = rocm-smi
pkgdesc = Utility to manage and monitor AMDGPU / ROCm systems.
- pkgver = 2.0.0
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://github.com/RadeonOpenCompute/ROC-smi/
arch = any
license = MIT
depends = python
- source = rocm-smi-2.0.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-2.0.0.tar.gz
- source = temporary-fixpoweroverdrive.patch
- sha256sums = 47b84798c95724708346ab505662a05a9a16e0fa0129b4371c073939d1c9fd35
- sha256sums = ce8984c6449c24af0eefba3a3afed2666ccc7bd42cafcba17512d514169d97c8
+ source = rocm-smi-2.1.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-2.1.0.tar.gz
+ sha256sums = fee0be144811dfa9cae2ec135a61a4c448a2eda235527a0cfb2dc3f3f1c051ed
pkgname = rocm-smi
diff --git a/PKGBUILD b/PKGBUILD
index a56a04bc0447..fee93f8b0b93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,15 @@
# Maintainer: Rigo Reddig <rigo.reddig@gmail.com>
pkgname=rocm-smi
-pkgver=2.0.0
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
_filename=roc-${pkgver}.tar.gz
pkgdesc="Utility to manage and monitor AMDGPU / ROCm systems."
arch=('any')
url="https://github.com/RadeonOpenCompute/ROC-smi/"
license=('MIT')
depends=(python)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/${_filename}"
- "temporary-fixpoweroverdrive.patch")
-sha256sums=('47b84798c95724708346ab505662a05a9a16e0fa0129b4371c073939d1c9fd35'
- 'ce8984c6449c24af0eefba3a3afed2666ccc7bd42cafcba17512d514169d97c8')
-
-prepare() {
- cd "ROC-smi-roc-${pkgver}"
- patch -Np1 -i "${srcdir}/temporary-fixpoweroverdrive.patch"
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/${_filename}")
+sha256sums=('fee0be144811dfa9cae2ec135a61a4c448a2eda235527a0cfb2dc3f3f1c051ed')
package() {
diff --git a/temporary-fixpoweroverdrive.patch b/temporary-fixpoweroverdrive.patch
deleted file mode 100644
index c720c6e317ef..000000000000
--- a/temporary-fixpoweroverdrive.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff --git a/rocm_smi.py b/rocm_smi.py
-index 3903b5b..b138855 100755
---- a/rocm_smi.py
-+++ b/rocm_smi.py
-@@ -1081,6 +1081,11 @@ def setPowerOverDrive(deviceList, value, autoRespond):
- return
-
- confirmOutOfSpecWarning(autoRespond)
-+
-+ # Value in Watt - stored early this way to avoid pythons float -> int -> str conversion after dividing a number
-+ strValue = value
-+ # Our Watt value converted for sysfs as microWatt
-+ value = int(value) * 1000000
-
- for device in deviceList:
- if not isDPMAvailable(device):
-@@ -1092,27 +1097,28 @@ def setPowerOverDrive(deviceList, value, autoRespond):
- continue
- power_cap_path = os.path.join(hwmon, 'power1_cap')
-
-- max_power_cap = str(int(getSysfsValue(device, 'power_cap_max')) / 1000000)
-- min_power_cap = str(int(getSysfsValue(device, 'power_cap_min')) / 1000000)
-+ # Avoid early unnecessary conversions
-+ max_power_cap = int(getSysfsValue(device, 'power_cap_max'))
-+ min_power_cap = int(getSysfsValue(device, 'power_cap_min'))
-
-- if int(value) < int(min_power_cap):
-- printLog(device, 'Unable to set Power OverDrive to less than ' + min_power_cap + 'W')
-+ if value < min_power_cap:
-+ printLog(device, 'Unable to set Power OverDrive to less than ' + str(min_power_cap / 1000000) + 'W')
- RETCODE = 1
- return
-
-- if int(value) > int(max_power_cap):
-- printLog(device, 'Unable to set Power OverDrive to more than ' + max_power_cap + 'W')
-+ if value > max_power_cap:
-+ printLog(device, 'Unable to set Power OverDrive to more than ' + str(max_power_cap / 1000000) + 'W')
- RETCODE = 1
- return;
-
-- if writeToSysfs(power_cap_path, str(int(value) * 1000000)):
-- if int(value) != 0:
-- printLog(device, 'Successfully set Power OverDrive to ' + value + 'W')
-+ if writeToSysfs(power_cap_path, str(value)):
-+ if value != 0:
-+ printLog(device, 'Successfully set Power OverDrive to ' + strValue + 'W')
- else:
- printLog(device, 'Successfully reset Power OverDrive')
- else:
-- if int(value) != 0:
-- printLog(device, 'Unable to set Power OverDrive to ' + value + 'W')
-+ if value != 0:
-+ printLog(device, 'Unable to set Power OverDrive to ' + strValue + 'W')
- else:
- printLog(device, 'Unable to reset Power OverDrive to default')
-