summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrigred2019-11-30 17:51:28 +0200
committerrigred2019-11-30 17:51:28 +0200
commitaf425e3823fcb3b3971d64bf150320dd83ec7bc2 (patch)
tree5afb14122e64328bf821ee8b9abf0fd736f3c0d6
parent6eb80c6878334f74101d849628f3123b86e23a6f (diff)
downloadaur-af425e3823fcb3b3971d64bf150320dd83ec7bc2.tar.gz
rocm-smi 2.10.0
* Force python2 as env param for now * Bug fix release * NB: Shout at AMD to rebase rocm-smi to Python 3 Signed-off-by: Rigo Reddig <rigo.reddig@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--python2_fix.patch8
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 369bc86657bd..9d72a964a499 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = rocm-smi
pkgdesc = Utility to manage and monitor AMDGPU / ROCm systems.
- pkgver = 2.9.0
+ pkgver = 2.10.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/ROC-smi/
arch = any
license = MIT
depends = python
- source = rocm-smi-2.9.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-2.9.0.tar.gz
- sha256sums = a7f97a5c23c54c08b0da421f7f6451241087d78ddb9722e79de5050c23f47dc3
+ source = rocm-smi-2.10.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-2.10.0.tar.gz
+ source = python2_fix.patch
+ sha256sums = 8ed448491db59b0d586dff7475ec8c40b8fca2063c480f31c721f64b22a44326
+ sha256sums = 986f8021c0dc2c3bd8f2fa81f82c1c6cbe8e506e708b04840ea5d3c935f16832
pkgname = rocm-smi
diff --git a/PKGBUILD b/PKGBUILD
index 8bb695c1a079..f82f8ec3500d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rigo Reddig <rigo.reddig@gmail.com>
pkgname=rocm-smi
-pkgver=2.9.0
+pkgver=2.10.0
pkgrel=1
_filename=roc-${pkgver}.tar.gz
pkgdesc="Utility to manage and monitor AMDGPU / ROCm systems."
@@ -8,8 +8,15 @@ arch=('any')
url="https://github.com/RadeonOpenCompute/ROC-smi/"
license=('MIT')
depends=(python)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/${_filename}")
-sha256sums=('a7f97a5c23c54c08b0da421f7f6451241087d78ddb9722e79de5050c23f47dc3')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/${_filename}"
+ "python2_fix.patch")
+sha256sums=('8ed448491db59b0d586dff7475ec8c40b8fca2063c480f31c721f64b22a44326'
+ '986f8021c0dc2c3bd8f2fa81f82c1c6cbe8e506e708b04840ea5d3c935f16832')
+
+prepare() {
+ cd "${srcdir}/ROC-smi-roc-${pkgver}"
+ patch --forward --input="${srcdir}/python2_fix.patch"
+}
package() {
diff --git a/python2_fix.patch b/python2_fix.patch
new file mode 100644
index 000000000000..7125be675949
--- /dev/null
+++ b/python2_fix.patch
@@ -0,0 +1,8 @@
+--- src/ROC-smi-roc-2.10.0/rocm_smi.py 2019-11-30 17:33:18.348444143 +0200
++++ src/ROC-smi-roc-2.10.0/rocm_smi.py 2019-11-30 17:29:46.753455838 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ """ ROCm-SMI (System Management Interface) Tool
+
+ This tool provides a user-friendly interface for manipulating