summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrigred2019-03-13 15:22:54 +0200
committerrigred2019-03-13 15:22:54 +0200
commitf9ef5cb212e2eeab07e7e13445b500cbf07c867a (patch)
tree5549965b00387e48e232e5f00aa1f819fe8189c4
parent75b7c35b4c8f0b8cd1fee8239a6eb8aa98723c03 (diff)
downloadaur-f9ef5cb212e2eeab07e7e13445b500cbf07c867a.tar.gz
rocm-smi 2.2.0
Add support for showing PCIe bandwidth Add support for displaying the estimated usage of PCIe bandwidth over the last second. This sysfs file will report the estimated bytes received and sent over the last second, as well as the maximum packet size, and the SMI will calculate estimated bandwidth using those values. Properly allow setting more than one DPM mask Previously, by concatenating all of the values for SetClocks together without spaces between them, we would try to combine multiple requested DPM states into a single string of integers. For example, trying to set "--setsclk 0 2 4 6" should "turn on" SCLK DPM states 0, 2, 4, and 6. This would try to set 0246 which resulted in wrong masks being put into the driver. We should still check that all the values being sent in are integers, so this patch first makes one fully-concatenated variable and ensures that it is still an integers. However, it actually passes in to sysfs a value that is space separated. Don't include non-AMD devices by default Only list/control AMD devices unless the --alldevices flag is passed in, this will avoid printing a bunch of unsupported fields, since it's not up to our kernel to support them. And avoid a bunch of error message regarding being unable to set values on devices that aren't AMD GPUs Some things may be usable, depending on the driver code in the upstream kernel (like temperature or fan speed on certain GPUs), but for the most part, it's stuff that the SMI can't control, which just wastes screen space, and most users don't care about trying to manage AMD and non-AMD devices in the same tool. The ones that do can use --alldevices Fix logic for checking max level 0 can be a max level, so check that the level is None, don't check that level isn't "false" , since 0 is a valid return for the function Since 0 is a valid return, change a failure to read from sysfs to None, and check the getMaxLevel returns instead of assuming that they worked Signed-off-by: Rigo Reddig <rigo.reddig@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ac55ee2a286..a95a8ce030f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = rocm-smi
pkgdesc = Utility to manage and monitor AMDGPU / ROCm systems.
- pkgver = 2.1.0
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/ROC-smi/
arch = any
license = MIT
depends = python
- source = rocm-smi-2.1.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-2.1.0.tar.gz
- sha256sums = fee0be144811dfa9cae2ec135a61a4c448a2eda235527a0cfb2dc3f3f1c051ed
+ source = rocm-smi-2.2.0.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/roc-2.2.0.tar.gz
+ sha256sums = 08e48412eb4b737cdbde046bceff2ab6efb2bd6c6614ab7886ad962ffbf5b5fa
pkgname = rocm-smi
diff --git a/PKGBUILD b/PKGBUILD
index fee93f8b0b93..1566e2ab1827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rigo Reddig <rigo.reddig@gmail.com>
pkgname=rocm-smi
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
_filename=roc-${pkgver}.tar.gz
pkgdesc="Utility to manage and monitor AMDGPU / ROCm systems."
@@ -9,7 +9,7 @@ url="https://github.com/RadeonOpenCompute/ROC-smi/"
license=('MIT')
depends=(python)
source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/ROC-smi/archive/${_filename}")
-sha256sums=('fee0be144811dfa9cae2ec135a61a4c448a2eda235527a0cfb2dc3f3f1c051ed')
+sha256sums=('08e48412eb4b737cdbde046bceff2ab6efb2bd6c6614ab7886ad962ffbf5b5fa')
package() {