summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-06-05 18:51:13 -0400
committeracxz2020-06-05 18:51:13 -0400
commita3c881b9b41eb8fdf30fb061773e89a6f4a95969 (patch)
tree5607db7f96d261028450717c2e27a53a46287ce8
downloadaur-a3c881b9b41eb8fdf30fb061773e89a6f4a95969.tar.gz
create rocm-smi-lib64 package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..814a3c907f3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rocm-smi-lib64
+ pkgdesc = ROCm SMI LIB
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = https://github.com/RadeonOpenCompute/rocm_smi_lib
+ arch = x86_64
+ license = custom:NCSAOSL
+ makedepends = cmake
+ options = !staticlibs
+ options = strip
+ source = rocm-smi-lib64-3.5.0.tar.gz::https://github.com/RadeonOpenCompute/rocm_smi_lib/archive/rocm-3.5.0.tar.gz
+ sha256sums = a5d2ec3570d018b60524f0e589c4917f03d26578443f94bde27a170c7bb21e6e
+
+pkgname = rocm-smi-lib64
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3747b4c15f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=rocm-smi-lib64
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="ROCm SMI LIB"
+arch=('x86_64')
+url="https://github.com/RadeonOpenCompute/rocm_smi_lib"
+license=('custom:NCSAOSL')
+depends=()
+makedepends=('cmake')
+options=(!staticlibs strip)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RadeonOpenCompute/rocm_smi_lib/archive/rocm-$pkgver.tar.gz")
+sha256sums=('a5d2ec3570d018b60524f0e589c4917f03d26578443f94bde27a170c7bb21e6e')
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ "$srcdir/rocm_smi_lib-rocm-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir" install
+}