summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodyfish2020-11-02 22:35:54 +0100
committerGitHub2020-11-02 16:35:54 -0500
commit77d46e005d2de4fdb14b51a5456de3a582a701ca (patch)
treed5cf83c998237ef1d0d8f087dd39e010fa5b2e8f
parent8a1abd2a8450d8d543aedbe1a564d0500193fc6e (diff)
downloadaur-77d46e005d2de4fdb14b51a5456de3a582a701ca.tar.gz
Patched pacman-specific solution for action command_string (#465)
Co-authored-by: Akash Patel <17132214+acxz@users.noreply.github.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--action.patch18
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b556d8edccc3..9d655839c8ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rocm-validation-suite
pkgdesc = Tool for detecting and troubleshooting common problems affecting AMD GPUs
pkgver = 3.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ROCm-Developer-Tools/ROCmValidationSuite
arch = x86_64
license = MIT
@@ -14,7 +14,9 @@ pkgbase = rocm-validation-suite
options = !staticlibs
options = strip
source = rocm-validation-suite-3.9.0.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-3.9.0.tar.gz
+ source = action.patch
sha256sums = 17662028a4485b97e3ccaad5e94d20aaa2c3e9e3f741c7ebbf0f8b4cdebcc555
+ sha256sums = 8edac06b0658c77f91ce77bbfbe539c4f001b27ab205aabcad91cbecf19bd4d0
pkgname = rocm-validation-suite
diff --git a/PKGBUILD b/PKGBUILD
index a56de1042dde..b9721a335a2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=rocm-validation-suite
pkgver=3.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Tool for detecting and troubleshooting common problems affecting AMD
GPUs"
arch=('x86_64')
@@ -10,8 +10,15 @@ license=('MIT')
depends=('pciutils' 'doxygen' 'rocblas' 'rocm-smi-lib64' 'git')
makedepends=('cmake')
options=(!staticlibs strip)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-$pkgver.tar.gz")
-sha256sums=('17662028a4485b97e3ccaad5e94d20aaa2c3e9e3f741c7ebbf0f8b4cdebcc555')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-$pkgver.tar.gz"
+ "action.patch")
+sha256sums=('17662028a4485b97e3ccaad5e94d20aaa2c3e9e3f741c7ebbf0f8b4cdebcc555'
+ '8edac06b0658c77f91ce77bbfbe539c4f001b27ab205aabcad91cbecf19bd4d0')
+
+prepare() {
+ cd "$srcdir/ROCmValidationSuite-rocm-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/action.patch"
+}
build() {
mkdir -p "$srcdir/build"
diff --git a/action.patch b/action.patch
new file mode 100644
index 000000000000..5cc29c6c6232
--- /dev/null
+++ b/action.patch
@@ -0,0 +1,18 @@
+diff --unified --recursive --text package.orig/rcqt.so/src/action.cpp package.new/rcqt.so/src/action.cpp
+--- package.orig/rcqt.so/src/action.cpp 2020-11-02 20:52:54.346675345 +0100
++++ package.new/rcqt.so/src/action.cpp 2020-11-02 20:53:23.430008727 +0100
+@@ -196,13 +196,7 @@
+ // Checking if version field exists
+ string version_name;
+ version_exists = has_property(VERSION, &version_name);
+- #if RVS_OS_TYPE_NUM == 1
+- string command_string = "dpkg --get-selections > ";
+- #endif
+- #if RVS_OS_TYPE_NUM == 2
+- string command_string = "rpm -qa --qf \"%{NAME}\n\" > ";
+- #endif
+- command_string += PKG_CMD_FILE;
++ string command_string = "pacman -Q > ";
+
+ // We execute the dpkg-querry
+ if (system(command_string.c_str()) == -1) {