summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkash Patel2022-02-28 11:17:28 -0500
committerGitHub2022-02-28 17:17:28 +0100
commitc8d9de20dd7366ccfa263204d4f4829cc0e52d61 (patch)
tree89d2629b51bd7849a56b61a805f35f93b3a41a12
parent71dd4030c4745283c7ed1326113ff39330716e86 (diff)
downloadaur-c8d9de20dd7366ccfa263204d4f4829cc0e52d61.tar.gz
upgpkg: rocm-validation-suite 5.0.1 (#662)
* upgpkg: rocm-validation-suite 5.0.0 * upgpkg: rocm-validation-suite 5.0.1-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--action.patch18
3 files changed, 28 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65783364ab26..8b1f4b52df01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocm-validation-suite
pkgdesc = Tool for detecting and troubleshooting common problems affecting AMD GPUs
- pkgver = 3.10.0
+ pkgver = 5.0.1
pkgrel = 1
url = https://github.com/ROCm-Developer-Tools/ROCmValidationSuite
arch = x86_64
@@ -11,12 +11,15 @@ pkgbase = rocm-validation-suite
depends = rocblas
depends = rocm-smi-lib64
depends = git
+ depends = libpciaccess
options = !staticlibs
options = strip
- source = rocm-validation-suite-3.10.0.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-3.10.0.tar.gz
- source = action.patch
- sha256sums = 9f9a530f7850770663e0b0ec0c786367f2e22500a472ac6652c4fd9fb4df4f64
- sha256sums = 8edac06b0658c77f91ce77bbfbe539c4f001b27ab205aabcad91cbecf19bd4d0
+ options = !lto
+ source = rocm-validation-suite-5.0.1.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-5.0.1.tar.gz
+ source = gtest.patch::https://patch-diff.githubusercontent.com/raw/ROCm-Developer-Tools/ROCmValidationSuite/pull/523.patch
+ source = rvs-os-type.patch::https://github.com/acxz/ROCmValidationSuite/commit/eb1a4bf5de8d8ba25f21ee13d6af1c46416e3961.patch
+ sha256sums = d4348bb2894e64727daba8006b9ae5b64622051aeef637442be069ecd5ce10c8
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = rocm-validation-suite
-
diff --git a/PKGBUILD b/PKGBUILD
index 348d945efc8a..e4f8565114f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,39 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: codyfish <fe27 at gmx dot net>
+# Contributor: sofiageo <george at sofianos dot dev>
pkgname=rocm-validation-suite
-pkgver=3.10.0
+pkgver=5.0.1
pkgrel=1
pkgdesc="Tool for detecting and troubleshooting common problems affecting AMD
GPUs"
arch=('x86_64')
url="https://github.com/ROCm-Developer-Tools/ROCmValidationSuite"
license=('MIT')
-depends=('pciutils' 'doxygen' 'rocblas' 'rocm-smi-lib64' 'git')
+depends=('pciutils' 'doxygen' 'rocblas' 'rocm-smi-lib64' 'git' 'libpciaccess')
makedepends=('cmake')
-options=(!staticlibs strip)
+options=(!staticlibs strip !lto)
source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-$pkgver.tar.gz"
- "action.patch")
-sha256sums=('9f9a530f7850770663e0b0ec0c786367f2e22500a472ac6652c4fd9fb4df4f64'
- '8edac06b0658c77f91ce77bbfbe539c4f001b27ab205aabcad91cbecf19bd4d0')
+ "gtest.patch::https://patch-diff.githubusercontent.com/raw/ROCm-Developer-Tools/ROCmValidationSuite/pull/523.patch"
+ "rvs-os-type.patch::https://github.com/acxz/ROCmValidationSuite/commit/eb1a4bf5de8d8ba25f21ee13d6af1c46416e3961.patch")
+sha256sums=('d4348bb2894e64727daba8006b9ae5b64622051aeef637442be069ecd5ce10c8'
+ 'SKIP'
+ 'SKIP')
prepare() {
cd "$srcdir/ROCmValidationSuite-rocm-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/action.patch"
+ patch --forward --strip=1 --input="${srcdir}/gtest.patch"
+ patch --forward --strip=1 --input="${srcdir}/rvs-os-type.patch"
}
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
- cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/rvs \
+ # -fcf-protection is not supported by HIP, see
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/develop/docs/markdown/clang_options.md
+ CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
+ cmake -DROCM_PATH=/opt/rocm \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
"$srcdir/ROCmValidationSuite-rocm-$pkgver"
make
}
@@ -37,7 +46,7 @@ package() {
# add links
install -d "$pkgdir/usr/bin"
local _fn
- for _fn in rocm_validation_suite; do
- ln -s "/opt/rocm/rvs/bin/$_fn" "$pkgdir/usr/bin/$_fn"
+ for _fn in rvs; do
+ ln -s "/opt/rocm/rvs/$_fn" "$pkgdir/usr/bin/$_fn"
done
}
diff --git a/action.patch b/action.patch
deleted file mode 100644
index 5cc29c6c6232..000000000000
--- a/action.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --unified --recursive --text package.orig/rcqt.so/src/action.cpp package.new/rcqt.so/src/action.cpp
---- package.orig/rcqt.so/src/action.cpp 2020-11-02 20:52:54.346675345 +0100
-+++ package.new/rcqt.so/src/action.cpp 2020-11-02 20:53:23.430008727 +0100
-@@ -196,13 +196,7 @@
- // Checking if version field exists
- string version_name;
- version_exists = has_property(VERSION, &version_name);
-- #if RVS_OS_TYPE_NUM == 1
-- string command_string = "dpkg --get-selections > ";
-- #endif
-- #if RVS_OS_TYPE_NUM == 2
-- string command_string = "rpm -qa --qf \"%{NAME}\n\" > ";
-- #endif
-- command_string += PKG_CMD_FILE;
-+ string command_string = "pacman -Q > ";
-
- // We execute the dpkg-querry
- if (system(command_string.c_str()) == -1) {