summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2020-03-03 23:55:45 -0500
committerneeshy2020-03-07 14:29:30 -0500
commite1d7e1023bd07188cd064d8f5db62584509b08f2 (patch)
tree4ee902a5fe64878e74b4e146b34401dd96265676
parent80be03b5eeae9622cf8c90fcb0d84a5d562aa53f (diff)
downloadaur-e1d7e1023bd07188cd064d8f5db62584509b08f2.tar.gz
Cleanup
Consistent style across project Remove extraneous dependencies Update packages Update checksums and .SRCINFO Specify proper license Fix prefixes Prefer make to ninja Much more TODO: miopen, rocm-cmake{,-git}, rock-dkms{,-git}, Remove duplicates in makedepends and depends git submodules
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD40
2 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95d5c7e7deb1..c820608197fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = rocprim
pkgdesc = ROCm Parallel Primitives
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/rocPRIM
arch = x86_64
- license = NCSAOSL
- makedepends = git
+ license = custom:NCSAOSL
makedepends = cmake
- makedepends = gcc
- makedepends = make
makedepends = hcc
makedepends = python2
makedepends = rocminfo
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/rocPRIM/archive/3.0.0.tar.gz
- sha256sums = cf3b14b700795c238cf0a0ab4dedca092cdc83f797e4c6331fba33a9f6358526
+ source = https://github.com/ROCmSoftwarePlatform/rocPRIM/archive/3.1.0.tar.gz
+ sha256sums = ef93668ce6b740e9e01688937846b406407a893c2effc0719e876acce5998b3a
pkgname = rocprim
diff --git a/PKGBUILD b/PKGBUILD
index 6ea22880857d..6eb359590ef1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,43 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocprim
-pkgver=3.0.0
+pkgver=3.1.0
pkgrel=1
pkgdesc="ROCm Parallel Primitives"
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/rocPRIM"
-license=('NCSAOSL')
-depends=(hcc hip)
-makedepends=(git cmake gcc make hcc python2 rocminfo)
-srcver="3.0.0"
-source=("https://github.com/ROCmSoftwarePlatform/rocPRIM/archive/$srcver.tar.gz")
-sha256sums=("cf3b14b700795c238cf0a0ab4dedca092cdc83f797e4c6331fba33a9f6358526")
+license=('custom:NCSAOSL')
+depends=('hcc' 'hip')
+makedepends=('cmake' 'hcc' 'python2' 'rocminfo')
+source=("https://github.com/ROCmSoftwarePlatform/rocPRIM/archive/$pkgver.tar.gz")
+sha256sums=('ef93668ce6b740e9e01688937846b406407a893c2effc0719e876acce5998b3a')
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
# fix broken build with stack protection
- export CXXFLAGS=$(echo $CXXFLAGS | sed -e 's/-fstack-protector-strong//')
- export CFLAGS=$(echo $CFLAGS | sed -e 's/-fstack-protector-strong//')
- export CPPFLAGS=$(echo $CPPFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CFLAGS")"
+ export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
+ export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
# compile with HCC
- export CXX=/opt/rocm/hcc/bin/hcc
+ export CXX="/opt/rocm/hcc/bin/hcc"
# TODO: fix librocprim.so, it contains references to $srcdir
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/rocprim" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocprim \
-DBUILD_TEST=OFF \
- -G Ninja \
- "$srcdir/rocPRIM-$srcver"
- ninja
+ "$srcdir/rocPRIM-$pkgver"
+ make
}
package() {
- ninja -C "$srcdir/build" install
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir"
- mkdir -p $pkgdir/etc/ld.so.conf.d
- cat <<-EOF > $pkgdir/etc/ld.so.conf.d/rocprim.conf
- /opt/rocm/rocprim/lib/
- EOF
+ install -d "$pkgdir/etc/ld.so.conf.d"
+ cat << EOF > "$pkgdir/etc/ld.so.conf.d/rocprim.conf"
+/opt/rocm/rocprim/lib
+EOF
}