summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-04-03 19:51:19 +0200
committerTorsten Keßler2022-04-03 19:51:19 +0200
commit34fdd8028ec9f97a8795d382ff472ea54822ae28 (patch)
treeeba51f452e663422015fda4a9467a43ec36be7fe
parent3746a8eacc9dbca645f26c0017b26623c5e9f086 (diff)
downloadaur-34fdd8028ec9f97a8795d382ff472ea54822ae28.tar.gz
upgpkg: rocsparse 5.1.0-1
upstream release Add new logic for AMDGPU_TARGETS
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 128029bc506d..1aced4cb0d80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocsparse
pkgdesc = BLAS for sparse computation on top of ROCm
- pkgver = 5.0.2
+ pkgver = 5.1.0
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocsparse
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = rocsparse
makedepends = gcc-fortran
depends = hip
depends = rocprim
- source = rocsparse-5.0.2.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-5.0.2.tar.gz
- sha256sums = c9d9e1b7859e1c5aa5050f5dfdf86245cbd7c1296c0ce60d9ca5f3e22a9b748b
+ source = rocsparse-5.1.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-5.1.0.tar.gz
+ sha256sums = a2f0f8cb02b95993480bd7264fc65e8b11464a90b86f2dcd0dd82a2e6d4bd704
pkgname = rocsparse
diff --git a/PKGBUILD b/PKGBUILD
index e8ac82d6815c..1c3bbd117338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
-pkgver=5.0.2
+pkgver=5.1.0
pkgrel=1
pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
@@ -11,20 +11,24 @@ depends=('hip' 'rocprim')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('c9d9e1b7859e1c5aa5050f5dfdf86245cbd7c1296c0ce60d9ca5f3e22a9b748b')
+sha256sums=('a2f0f8cb02b95993480bd7264fc65e8b11464a90b86f2dcd0dd82a2e6d4bd704')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
- # -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.0.x/docs/markdown/clang_options.md
+ local cmake_flags=(
+ '-DCMAKE_INSTALL_PREFIX=/opt/rocm'
+ '-Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim'
+ '-DBUILD_CLIENTS_SAMPLES=OFF')
+ if [[ -n "$AMDGPU_TARGETS" ]]; then
+ cmake_flags+=("-DAMDGPU_TARGETS=$AMDGPU_TARGETS")
+ fi
+ # -fcf-protection is not supported by HIP, see
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.1.x/docs/markdown/clang_options.md
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim \
- -DBUILD_CLIENTS_SAMPLES=OFF \
- -DAMDGPU_TARGETS=${AMDGPU_TARGETS:-gfx803;gfx900:xnack-;gfx906:xnack-;gfx908:xnack-;gfx90a:xnack-;gfx90a:xnack+;gfx1030}
+ "${cmake_flags[@]}"
make
}