summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-03-18 04:02:55 -0500
committerGitHub2022-03-18 10:02:55 +0100
commit41ea661280c0305bcdd1417add1d0490949bdadd (patch)
treeb1a72bfa623681de04bd0cf851a84b28acb50095
parent92a9483ec58b2f773c50caaeb3c6fbc060bd4e61 (diff)
downloadaur-41ea661280c0305bcdd1417add1d0490949bdadd.tar.gz
Use cmake -DAMDGPU_TARGETS=${AMDGPU_TARGETS} to specify GPU targets (#650)
hip-runtime-amd https://github.com/ROCm-Developer-Tools/hipamd/blob/develop/hip-config.cmake.in#L165 hipcub https://github.com/ROCmSoftwarePlatform/hipCUB/blob/develop/CMakeLists.txt#L62 hipfft https://github.com/ROCmSoftwarePlatform/hipfft/blob/develop/CMakeLists.txt#L108 rccl https://github.com/ROCmSoftwarePlatform/rccl/blob/develop/CMakeLists.txt#L45 rocalution https://github.com/ROCmSoftwarePlatform/rocalution/blob/develop/CMakeLists.txt#L84 rocblas https://github.com/ROCmSoftwarePlatform/rocblas/blob/develop/CMakeLists.txt#L91 rocfft https://github.com/ROCmSoftwarePlatform/rocfft/blob/develop/CMakeLists.txt#L142 rocrand https://github.com/ROCmSoftwarePlatform/rocrand/blob/develop/CMakeLists.txt#L79 rocsolver https://github.com/ROCmSoftwarePlatform/rocsolver/blob/develop/CMakeLists.txt#L128 rocsparse https://github.com/ROCmSoftwarePlatform/rocsparse/blob/develop/CMakeLists.txt#L158 rocthrust https://github.com/ROCmSoftwarePlatform/rocthrust/blob/develop/CMakeLists.txt#L68
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a5827d9a653..86734c90202a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,8 @@ build() {
cmake -Wno-dev -S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim \
- -DBUILD_CLIENTS_SAMPLES=OFF
+ -DBUILD_CLIENTS_SAMPLES=OFF \
+ -DAMDGPU_TARGETS=${AMDGPU_TARGETS}
make
}