summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-07-01 19:12:07 +0200
committerTorsten Keßler2022-07-01 19:12:07 +0200
commit45abe4c7f753d3b2f91d9d06a747f84605d48820 (patch)
treefc47c19e1ad184123953c29e91d13c0acdd37f0b
parentd68dd18c51bc233b4276dd564c2d3882b086ebc0 (diff)
downloadaur-45abe4c7f753d3b2f91d9d06a747f84605d48820.tar.gz
upgpkg: rocsparse 5.2.0-1
* Update checksum * Update links to official documentation
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7781e711ee87..2e01151cf222 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = rocsparse
pkgdesc = BLAS for sparse computation on top of ROCm
- pkgver = 5.1.3
+ pkgver = 5.2.0
pkgrel = 1
- url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocsparse
+ url = https://rocsparse.readthedocs.io/en/master/
arch = x86_64
license = MIT
makedepends = cmake
@@ -10,7 +10,7 @@ pkgbase = rocsparse
makedepends = gcc-fortran
depends = hip
depends = rocprim
- source = rocsparse-5.1.3.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-5.1.3.tar.gz
- sha256sums = ef9641045b36c9aacc87e4fe7717b41b1e29d97e21432678dce7aca633a8edc2
+ source = rocsparse-5.2.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-5.2.0.tar.gz
+ sha256sums = 7ed929af16d2502135024a6463997d9a95f03899b8a33aa95db7029575c89572
pkgname = rocsparse
diff --git a/PKGBUILD b/PKGBUILD
index 72bace9b5f6e..c854a0da5291 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
-pkgver=5.1.3
+pkgver=5.2.0
pkgrel=1
pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
-url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocsparse'
+url='https://rocsparse.readthedocs.io/en/master/'
license=('MIT')
depends=('hip' 'rocprim')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('ef9641045b36c9aacc87e4fe7717b41b1e29d97e21432678dce7aca633a8edc2')
+sha256sums=('7ed929af16d2502135024a6463997d9a95f03899b8a33aa95db7029575c89572')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
@@ -24,7 +24,7 @@ build() {
fi
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.1.x/docs/markdown/clang_options.md
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \