summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-08-07 12:22:34 +0200
committerTorsten Keßler2021-08-07 12:22:34 +0200
commit4b7802abf6a66b138699fc677d15e3e85445d577 (patch)
treee1cdec3cfd22bd7187b3930e43f83fc6d898bf12
parent4fe88d16aa61b80abbd9cafc84b67879e6ceeb0e (diff)
downloadaur-4b7802abf6a66b138699fc677d15e3e85445d577.tar.gz
upgpkg: rocsparse 4.3.0-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f866b6d605f..177d57f5684d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocsparse
pkgdesc = BLAS for sparse computation on top of ROCm
- pkgver = 4.2.0
+ pkgver = 4.3.0
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocsparse
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = rocsparse
makedepends = gcc-fortran
depends = hip-rocclr
depends = rocprim
- source = rocsparse-4.2.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-4.2.0.tar.gz
- sha256sums = 8a86ed49d278e234c82e406a1430dc28f50d416f8f1065cf5bdf25cc5721129c
+ source = rocsparse-4.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-4.3.0.tar.gz
+ sha256sums = 1a8109bdc8863b3acfe991449360c9361cae7cabdbe753c553bc57872cd0ad5e
pkgname = rocsparse
diff --git a/PKGBUILD b/PKGBUILD
index 4f40de793438..cc1a02f91860 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
-pkgver=4.2.0
+pkgver=4.3.0
pkgrel=1
pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
@@ -11,15 +11,19 @@ depends=('hip-rocclr' 'rocprim')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('8a86ed49d278e234c82e406a1430dc28f50d416f8f1065cf5bdf25cc5721129c')
+sha256sums=('1a8109bdc8863b3acfe991449360c9361cae7cabdbe753c553bc57872cd0ad5e')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.2.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.3.x/docs/markdown/clang_options.md
+
+ # With version 3.21, HIP support was added to CMake that breaks the current scripts, see
+ # https://github.com/ROCmSoftwarePlatform/rocRAND/issues/198#issuecomment-893573440
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
+ -D__skip_rocmclang=ON \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim \
-DBUILD_CLIENTS_SAMPLES=OFF