summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2019-06-12 17:51:15 +0200
committernaetherm2019-06-12 17:51:15 +0200
commitb611a5ad177532c88acfb8cce89d62df5b826d56 (patch)
tree60d68bdd472e591fb0a7ac1295ee4fe024d8d175
downloadaur-b611a5ad177532c88acfb8cce89d62df5b826d56.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD46
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d1b7df104eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = rocsparse
+ pkgdesc = Next generation SPARSE implementation for ROCm platform.
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/ROCmSoftwarePlatform/rocSPARSE
+ arch = x86_64
+ license = NCSAOSL
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = ninja
+ makedepends = hcc
+ makedepends = python2
+ makedepends = rocminfo
+ depends = hcc
+ depends = hip
+ source = https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-2.5.tar.gz
+ sha256sums = 01f5eae7cdd9cb98f6ff765e053afd36dfab61a3217016420afbda8dc6ae8b35
+
+pkgname = rocsparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeceddc95e65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
+pkgname=rocsparse
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Next generation SPARSE implementation for ROCm platform."
+arch=('x86_64')
+url="https://github.com/ROCmSoftwarePlatform/rocSPARSE"
+license=('NCSAOSL')
+depends=(hcc hip)
+makedepends=(git cmake gcc ninja hcc python2 rocminfo)
+srcver="2.5"
+source=("https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-$srcver.tar.gz")
+sha256sums=("01f5eae7cdd9cb98f6ff765e053afd36dfab61a3217016420afbda8dc6ae8b35")
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ # Tensile library needs python to be python2
+ export PATH="$srcdir:$PATH"
+ [[ -e "$srcdir/python" ]] || ln -s /usr/bin/python2 "$srcdir/python"
+
+ # fix broken build with stack protection
+ export CXXFLAGS=$(echo $CXXFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CFLAGS=$(echo $CFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CPPFLAGS=$(echo $CPPFLAGS | sed -e 's/-fstack-protector-strong//')
+
+ # compile with HCC
+ export CXX=/opt/rocm/hcc/bin/hcc
+
+ # TODO: fix librocsparse.so, it contains references to $srcdir
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/rocsparse" \
+ -G Ninja \
+ "$srcdir/rocSPARSE-rocm-$srcver"
+ ninja
+}
+
+package() {
+ ninja -C "$srcdir/build" install
+
+ mkdir -p $pkgdir/etc/ld.so.conf.d
+ cat <<-EOF > $pkgdir/etc/ld.so.conf.d/rocsparse.conf
+ /opt/rocm/rocsparse/lib/
+ EOF
+}