summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkash Patel2022-07-17 04:47:02 -0500
committerGitHub2022-07-17 11:47:02 +0200
commiteb901bf9bffcc6159a2f041eb641f2c4acfcffcb (patch)
tree3cad29105a7e3cf15bf509287ee48a30b9068870
parent45abe4c7f753d3b2f91d9d06a747f84605d48820 (diff)
downloadaur-eb901bf9bffcc6159a2f041eb641f2c4acfcffcb.tar.gz
upgpkg: rocsparse 5.2.0-2 (#822)
add patch to fix gfx1010 compilation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e01151cf222..81493c0c4818 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rocsparse
pkgdesc = BLAS for sparse computation on top of ROCm
pkgver = 5.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://rocsparse.readthedocs.io/en/master/
arch = x86_64
license = MIT
@@ -11,6 +11,8 @@ pkgbase = rocsparse
depends = hip
depends = rocprim
source = rocsparse-5.2.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-5.2.0.tar.gz
+ source = gfx1010.patch::https://github.com/ROCmSoftwarePlatform/rocSPARSE/commit/f8934f91f779c291a5cf1157ed58fc427544fd2d.patch
sha256sums = 7ed929af16d2502135024a6463997d9a95f03899b8a33aa95db7029575c89572
+ sha256sums = 97e250d386ba318550701bc0f0657d5f7ba282f301c7d81b1bbb1563af9dbe56
pkgname = rocsparse
diff --git a/PKGBUILD b/PKGBUILD
index c854a0da5291..8b80f1b46dd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
pkgver=5.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
url='https://rocsparse.readthedocs.io/en/master/'
@@ -10,10 +10,17 @@ license=('MIT')
depends=('hip' 'rocprim')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
-source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('7ed929af16d2502135024a6463997d9a95f03899b8a33aa95db7029575c89572')
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
+ "gfx1010.patch::$_git/commit/f8934f91f779c291a5cf1157ed58fc427544fd2d.patch")
+sha256sums=('7ed929af16d2502135024a6463997d9a95f03899b8a33aa95db7029575c89572'
+ '97e250d386ba318550701bc0f0657d5f7ba282f301c7d81b1bbb1563af9dbe56')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
+prepare() {
+ cd "$_dirname"
+ patch -Np1 -i "$srcdir/gfx1010.patch"
+}
+
build() {
local cmake_flags=(
'-DCMAKE_INSTALL_PREFIX=/opt/rocm'