summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2020-05-20 13:05:26 +0200
committerGitHub2020-05-20 07:05:26 -0400
commitec308632bdfdbaff1a35d46ea32367da1494f868 (patch)
tree8d7a40cebcb48ae83970c5d054d4e9fc549c1ca0
parentc538030fac9a78964f0d0fa758fd1266ee12f6b6 (diff)
downloadaur-ec308632bdfdbaff1a35d46ea32367da1494f868.tar.gz
[rocsparse] Successful build in clean chroot (#160)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 24 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8611e641488a..fc1dc5bef359 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = rocsparse
- pkgdesc = Next generation SPARSE implementation for ROCm platform.
+ pkgdesc = BLAS for sparse computation on top of ROCm
pkgver = 3.3.0
- pkgrel = 1
- url = https://github.com/ROCmSoftwarePlatform/rocSPARSE
+ pkgrel = 2
+ url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocsparse
arch = x86_64
- license = custom:NCSAOSL
+ license = MIT
makedepends = cmake
makedepends = hcc
- makedepends = python2
- makedepends = rocminfo
- depends = hcc
- depends = hip
- source = https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-3.3.0.tar.gz
+ makedepends = git
+ depends = hip-hcc
+ depends = rocprim
+ source = rocsparse-3.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-3.3.0.tar.gz
sha256sums = 04122317b21df69709a11b164b42e0f21f7fc745c2e28daeecb99ab01e7a8de3
pkgname = rocsparse
diff --git a/PKGBUILD b/PKGBUILD
index 0ca387a7036b..22a5b83cb078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,26 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocsparse
-_pkgver=3.3.0
-pkgver="$_pkgver"
-pkgrel=1
-pkgdesc="Next generation SPARSE implementation for ROCm platform."
+pkgver=3.3.0
+pkgrel=2
+pkgdesc='BLAS for sparse computation on top of ROCm'
arch=('x86_64')
-url="https://github.com/ROCmSoftwarePlatform/rocSPARSE"
-license=('custom:NCSAOSL')
-depends=('hcc' 'hip')
-makedepends=('cmake' 'hcc' 'python2' 'rocminfo')
-source=("https://github.com/ROCmSoftwarePlatform/rocSPARSE/archive/rocm-$_pkgver.tar.gz")
+url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocsparse'
+license=('MIT')
+depends=('hip-hcc' 'rocprim')
+makedepends=('cmake' 'hcc' 'git')
+_git='https://github.com/ROCmSoftwarePlatform/rocSPARSE'
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
sha256sums=('04122317b21df69709a11b164b42e0f21f7fc745c2e28daeecb99ab01e7a8de3')
build() {
- mkdir -p "$srcdir/build"
- cd "$srcdir/build"
-
- # Tensile library needs python to be python2
- export PATH="$srcdir:$PATH"
- [[ -e "$srcdir/python" ]] || ln -s /usr/bin/python2 "$srcdir/python"
-
- # fix broken build with stack protection
- export CFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CFLAGS")"
- export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
- export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
-
- # compile with HCC
- export CXX="/opt/rocm/hcc/bin/hcc"
+ mkdir -p build
+ cd build
- # TODO: fix librocsparse.so, it contains references to $srcdir
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocsparse \
+ CXX=/opt/rocm/hcc/bin/hcc \
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocsparse \
-Drocprim_DIR=/opt/rocm/rocprim/rocprim/lib/cmake/rocprim \
-DBUILD_CLIENTS_SAMPLES=OFF \
- "$srcdir/rocSPARSE-rocm-$_pkgver"
+ "$srcdir/rocSPARSE-rocm-$pkgver"
make
}
@@ -42,8 +29,8 @@ package() {
make DESTDIR="$pkgdir" install
- install -d "$pkgdir/etc/ld.so.conf.d"
- cat << EOF > "$pkgdir/etc/ld.so.conf.d/rocsparse.conf"
+ install -Dm644 /dev/stdin "$pkgdir/etc/ld.so.conf.d/rocsparse.conf" <<EOF
/opt/rocm/rocsparse/lib
EOF
+ install -Dm644 "$srcdir/rocSPARSE-rocm-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}