summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2020-06-06 17:14:34 +0200
committerGitHub2020-06-06 11:14:34 -0400
commit246ea47b1459501714a21906de7b4e055af5bbb8 (patch)
tree39a466f4fccb14ac7498da2930fecb063e8901c1
parentaeacfe610fe9aa92917a4b3f321eda0d682fd193 (diff)
downloadaur-246ea47b1459501714a21906de7b4e055af5bbb8.tar.gz
Update to 3.5.0 (#200)
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23e904559e44..02e764388982 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm
- pkgver = 3.3.0
- pkgrel = 4
+ pkgver = 3.5.0
+ pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust
arch = x86_64
license = Apache
makedepends = cmake
makedepends = git
- makedepends = hcc
- depends = hip-hcc
+ depends = hip-rocclr
depends = rocprim
- source = rocthrust-3.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-3.3.0.tar.gz
+ source = rocthrust-3.5.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-3.5.0.tar.gz
sha256sums = 5782c9b96233b2050168381b3c2259baeb410b859f68c25b2d14110fb1bb726f
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 9227ac7bd53b..39ab73423f38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=3.3.0
-pkgrel=4
+pkgver=3.5.0
+pkgrel=1
pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust'
license=('Apache')
-depends=('hip-hcc' 'rocprim')
-makedepends=('cmake' 'git' 'hcc')
+depends=('hip-rocclr' 'rocprim')
+makedepends=('cmake' 'git')
_git='https://github.com/ROCmSoftwarePlatform/rocThrust'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
sha256sums=('5782c9b96233b2050168381b3c2259baeb410b859f68c25b2d14110fb1bb726f')
@@ -16,8 +16,8 @@ build() {
mkdir -p build
cd build
- CXX=/opt/rocm/hcc/bin/hcc \
- cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocthrust \
+ CXX=/opt/rocm/hip/bin/hipcc \
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
-DBUILD_TEST=OFF \
"$srcdir/rocThrust-rocm-$pkgver"
@@ -27,7 +27,4 @@ package() {
cd "$srcdir/build"
make DESTDIR="$pkgdir" install
-
- install -d "$pkgdir/opt/rocm/include"
- ln -s /opt/rocm/rocthrust/include/thrust "$pkgdir/opt/rocm/include"
}