summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-08-08 14:15:05 +0200
committerTorsten Keßler2021-08-08 14:15:05 +0200
commit415f64f9b834a9bffa489cbbe34a8a1bd506e67a (patch)
treef8e0c76d5d2cf66310a6fe77ebf759405dc5e1f2
parent6978048e2ff938071ef3ed91575379a110184524 (diff)
downloadaur-415f64f9b834a9bffa489cbbe34a8a1bd506e67a.tar.gz
upgpkg: rocthrust 4.3.0-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27059532ad2f..7825e825be77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm
- pkgver = 4.2.0
+ pkgver = 4.3.0
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = rocthrust
makedepends = git
depends = hip-rocclr
depends = rocprim
- source = rocthrust-4.2.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-4.2.0.tar.gz
- sha256sums = da2b6c831c26c26058218b0c5b7b2e43fd7f0dac3b2e3a8e39a839145592c727
+ source = rocthrust-4.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-4.3.0.tar.gz
+ sha256sums = a50eb6500687b4ea9e0b3affb1daff8bbc56199d39fbed3ee61d2d5bfc1a0271
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 9446de512440..2baef5c5355c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=4.2.0
+pkgver=4.3.0
pkgrel=1
pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
arch=('x86_64')
@@ -11,15 +11,19 @@ depends=('hip-rocclr' 'rocprim')
makedepends=('cmake' 'git')
_git='https://github.com/ROCmSoftwarePlatform/rocThrust'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('da2b6c831c26c26058218b0c5b7b2e43fd7f0dac3b2e3a8e39a839145592c727')
+sha256sums=('a50eb6500687b4ea9e0b3affb1daff8bbc56199d39fbed3ee61d2d5bfc1a0271')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.2.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.3.x/docs/markdown/clang_options.md
+
+ # With version 3.21, HIP support was added to CMake that breaks the current scripts, see
+ # https://github.com/ROCmSoftwarePlatform/rocRAND/issues/198#issuecomment-893573440
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
+ -D__skip_rocmclang=ON \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
-DBUILD_TEST=OFF