summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-03-18 04:02:55 -0500
committerGitHub2022-03-18 10:02:55 +0100
commit4f9afb82fc3fb2e5da5e0a258dc6b2172ede0156 (patch)
tree9ea7793cd6fb253da26abf48499adcaacc50e581
parent48c919c4ff24dc93887e2667a4bb58b9c0dae9aa (diff)
downloadaur-4f9afb82fc3fb2e5da5e0a258dc6b2172ede0156.tar.gz
Use cmake -DAMDGPU_TARGETS=${AMDGPU_TARGETS} to specify GPU targets (#650)
hip-runtime-amd https://github.com/ROCm-Developer-Tools/hipamd/blob/develop/hip-config.cmake.in#L165 hipcub https://github.com/ROCmSoftwarePlatform/hipCUB/blob/develop/CMakeLists.txt#L62 hipfft https://github.com/ROCmSoftwarePlatform/hipfft/blob/develop/CMakeLists.txt#L108 rccl https://github.com/ROCmSoftwarePlatform/rccl/blob/develop/CMakeLists.txt#L45 rocalution https://github.com/ROCmSoftwarePlatform/rocalution/blob/develop/CMakeLists.txt#L84 rocblas https://github.com/ROCmSoftwarePlatform/rocblas/blob/develop/CMakeLists.txt#L91 rocfft https://github.com/ROCmSoftwarePlatform/rocfft/blob/develop/CMakeLists.txt#L142 rocrand https://github.com/ROCmSoftwarePlatform/rocrand/blob/develop/CMakeLists.txt#L79 rocsolver https://github.com/ROCmSoftwarePlatform/rocsolver/blob/develop/CMakeLists.txt#L128 rocsparse https://github.com/ROCmSoftwarePlatform/rocsparse/blob/develop/CMakeLists.txt#L158 rocthrust https://github.com/ROCmSoftwarePlatform/rocthrust/blob/develop/CMakeLists.txt#L68
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e68ec4bcbe0..0b2d4bdb1bc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,8 @@ build() {
cmake -Wno-dev -S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- -DBUILD_TEST=OFF
+ -DBUILD_TEST=OFF \
+ -DAMDGPU_TARGETS=${AMDGPU_TARGETS}
}
package() {