summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2020-04-07 07:06:13 +0200
committernaetherm2020-04-07 07:06:13 +0200
commit5986b4f2425a5cea4de9dec1fb6d6faa9a8171da (patch)
treec1e91045fa8618d123e6102965e2b950a9f01258
parent6b8d993b2722a2026e2f53b647e8a21341e43259 (diff)
downloadaur-5986b4f2425a5cea4de9dec1fb6d6faa9a8171da.tar.gz
Updated rocthrust to version 3.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7fd84757b6b..7f9364450bd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm.
- pkgver = 3.1.0
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/rocThrust
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = rocthrust
makedepends = rocm-comgr
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/3.1.0.tar.gz
- sha256sums = 87f6809b74422aed09f21a63eff09d4328791d6f622aa8040f104b55dbe5ae00
+ source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-3.3.0.tar.gz
+ sha256sums = 5782c9b96233b2050168381b3c2259baeb410b859f68c25b2d14110fb1bb726f
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 259bc054c9ef..d6fc2a228dc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=3.1.0
+pkgver=3.3.0
pkgrel=1
pkgdesc="Port of the Thrust parallel algorithm library atop HIP/ROCm."
arch=('x86_64')
@@ -8,8 +8,8 @@ url="https://github.com/ROCmSoftwarePlatform/rocThrust"
license=('custom:NCSAOSL')
depends=('hcc' 'hip')
makedepends=('cmake' 'hcc' 'python2' 'rocminfo' 'rocm-comgr')
-source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/$pkgver.tar.gz")
-sha256sums=('87f6809b74422aed09f21a63eff09d4328791d6f622aa8040f104b55dbe5ae00')
+source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-$pkgver.tar.gz")
+sha256sums=('5782c9b96233b2050168381b3c2259baeb410b859f68c25b2d14110fb1bb726f')
build() {
mkdir -p "$srcdir/build"
@@ -32,7 +32,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/opt/rocm/rocthrust \
-DBUILD_TEST=OFF \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- "$srcdir/rocThrust-$pkgver"
+ "$srcdir/rocThrust-rocm-$pkgver"
make
}