summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2020-03-03 23:55:45 -0500
committerneeshy2020-03-07 14:29:30 -0500
commit617838db2bf03cf25ba6923deeec85a0a2783321 (patch)
treeca4aa586ab9ebd8dab50853a64282572fb85ffc6
parent6f82d5f1fd5df8bc110c5ed8103c8a4756dd9dd0 (diff)
downloadaur-617838db2bf03cf25ba6923deeec85a0a2783321.tar.gz
Cleanup
Consistent style across project Remove extraneous dependencies Update packages Update checksums and .SRCINFO Specify proper license Fix prefixes Prefer make to ninja Much more TODO: miopen, rocm-cmake{,-git}, rock-dkms{,-git}, Remove duplicates in makedepends and depends git submodules
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD40
2 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5297e41a9d6a..a1648f91b03e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm.
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/rocThrust
arch = x86_64
- license = NCSAOSL
- makedepends = git
+ license = custom:NCSAOSL
makedepends = cmake
- makedepends = gcc
- makedepends = ninja
makedepends = hcc
makedepends = python2
makedepends = rocminfo
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/3.0.0.tar.gz
- sha256sums = 42fc7953e1b230a387851918cfd2490ac3d520f43f068d45fc348015196cabd8
+ source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/3.1.0.tar.gz
+ sha256sums = 87f6809b74422aed09f21a63eff09d4328791d6f622aa8040f104b55dbe5ae00
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 9d3e9db260e6..9ed5c33a2f0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=3.0.0
+pkgver=3.1.0
pkgrel=1
pkgdesc="Port of the Thrust parallel algorithm library atop HIP/ROCm."
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/rocThrust"
-license=('NCSAOSL')
-depends=(hcc hip)
-makedepends=(git cmake gcc ninja hcc python2 rocminfo)
-srcver="3.0.0"
-source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/$srcver.tar.gz")
-sha256sums=("42fc7953e1b230a387851918cfd2490ac3d520f43f068d45fc348015196cabd8")
+license=('custom:NCSAOSL')
+depends=('hcc' 'hip')
+makedepends=('cmake' 'hcc' 'python2' 'rocminfo')
+source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/$pkgver.tar.gz")
+sha256sums=('87f6809b74422aed09f21a63eff09d4328791d6f622aa8040f104b55dbe5ae00')
build() {
mkdir -p "$srcdir/build"
@@ -21,27 +20,28 @@ build() {
[[ -e "$srcdir/python" ]] || ln -s /usr/bin/python2 "$srcdir/python"
# fix broken build with stack protection
- export CXXFLAGS=$(echo $CXXFLAGS | sed -e 's/-fstack-protector-strong//')
- export CFLAGS=$(echo $CFLAGS | sed -e 's/-fstack-protector-strong//')
- export CPPFLAGS=$(echo $CPPFLAGS | sed -e 's/-fstack-protector-strong//')
+ export CFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CFLAGS")"
+ export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
+ export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
# compile with HCC
- export CXX=/opt/rocm/hcc/bin/hcc
+ export CXX="/opt/rocm/hcc/bin/hcc"
# TODO: fix librocthrust.so, it contains references to $srcdir
cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/rocthrust" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocthrust \
-DBUILD_TEST=OFF \
- -G Ninja \
- "$srcdir/rocThrust-$srcver"
- ninja
+ "$srcdir/rocThrust-$pkgver"
+ make
}
package() {
- ninja -C "$srcdir/build" install
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
- mkdir -p $pkgdir/etc/ld.so.conf.d
- cat <<-EOF > $pkgdir/etc/ld.so.conf.d/rocthrust.conf
- /opt/rocm/rocthrust/lib/
- EOF
+ intsall -d "$pkgdir/etc/ld.so.conf.d"
+ cat << EOF > "$pkgdir/etc/ld.so.conf.d/rocthrust.conf"
+/opt/rocm/rocthrust/lib
+EOF
}