summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2020-08-22 14:07:35 +0200
committerGitHub2020-08-22 08:07:35 -0400
commit6491839846eb0ef01e187c485faf0c3859f2d9f2 (patch)
treef4dc9c279dad3adb22f48f0e8af36796db101a50
parent5f8c6c3a1d0fcb512ad50a17df7c50ebf99cbf62 (diff)
downloadaur-6491839846eb0ef01e187c485faf0c3859f2d9f2.tar.gz
[rocthrust] Update to 3.7.0 (#375)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index beb6b8f0ba2f..c64c43b6235b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm
- pkgver = 3.5.0
- pkgrel = 2
+ pkgver = 3.7.0
+ pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust
arch = x86_64
license = Apache
@@ -9,8 +9,8 @@ pkgbase = rocthrust
makedepends = git
depends = hip-rocclr
depends = rocprim
- source = rocthrust-3.5.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-3.5.0.tar.gz
- sha256sums = 0d1bac1129d17bb1259fd06f5c9cb4c1620d1790b5c295b866fb3442d18923cb
+ source = rocthrust-3.7.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-3.7.0.tar.gz
+ sha256sums = 4cb923dde5eec150a566cb10d23ee5c7ce3aa892c4dea94886a89d95b90f3bdd
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 44d23eae181f..ac9a82275a9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=3.5.0
-pkgrel=2
+pkgver=3.7.0
+pkgrel=1
pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust'
@@ -10,21 +10,17 @@ depends=('hip-rocclr' 'rocprim')
makedepends=('cmake' 'git')
_git='https://github.com/ROCmSoftwarePlatform/rocThrust'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('0d1bac1129d17bb1259fd06f5c9cb4c1620d1790b5c295b866fb3442d18923cb')
+sha256sums=('4cb923dde5eec150a566cb10d23ee5c7ce3aa892c4dea94886a89d95b90f3bdd')
+_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
- mkdir -p build
- cd build
-
CXX=/opt/rocm/hip/bin/hipcc \
- cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ cmake -Wno-dev -S "$_dirname" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- -DBUILD_TEST=OFF \
- "$srcdir/rocThrust-rocm-$pkgver"
+ -DBUILD_TEST=OFF
}
package() {
- cd "$srcdir/build"
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make install
}