summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-05-14 09:55:33 +0200
committerTorsten Keßler2021-05-14 09:55:33 +0200
commit6978048e2ff938071ef3ed91575379a110184524 (patch)
tree2e149f059b0a5dab9ceb8f8f4e261c0d547f8e08
parent460706f1b8a1d7c59503fa3dcee82f0898d14aea (diff)
downloadaur-6978048e2ff938071ef3ed91575379a110184524.tar.gz
upgpkg: rocthrust 4.2.0-1
upstream release new release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a51f2186912e..27059532ad2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm
- pkgver = 4.1.0
- pkgrel = 2
+ pkgver = 4.2.0
+ pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust
arch = x86_64
license = Apache
@@ -9,7 +9,7 @@ pkgbase = rocthrust
makedepends = git
depends = hip-rocclr
depends = rocprim
- source = rocthrust-4.1.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-4.1.0.tar.gz
- sha256sums = e3d06c0387a2a6880776c7423b1acf0808fb8833bc822be75793da8c2f521efd
+ source = rocthrust-4.2.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-4.2.0.tar.gz
+ sha256sums = da2b6c831c26c26058218b0c5b7b2e43fd7f0dac3b2e3a8e39a839145592c727
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index f8e5d1dd4296..9446de512440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=4.1.0
-pkgrel=2
+pkgver=4.2.0
+pkgrel=1
pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust'
@@ -11,11 +11,14 @@ depends=('hip-rocclr' 'rocprim')
makedepends=('cmake' 'git')
_git='https://github.com/ROCmSoftwarePlatform/rocThrust'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('e3d06c0387a2a6880776c7423b1acf0808fb8833bc822be75793da8c2f521efd')
+sha256sums=('da2b6c831c26c26058218b0c5b7b2e43fd7f0dac3b2e3a8e39a839145592c727')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
+ # -fcf-protection is not supported by HIP, see
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.2.x/docs/markdown/clang_options.md
CXX=/opt/rocm/bin/hipcc \
+ CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \