summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2020-01-09 07:35:30 +0100
committernaetherm2020-01-09 07:35:30 +0100
commit6f82d5f1fd5df8bc110c5ed8103c8a4756dd9dd0 (patch)
tree7a54effea1cb2f8eb352a6fb0879b23fbd9ae00e
parent882b289a5d1875bd0732b56892f6bc088ec0e1d2 (diff)
downloadaur-6f82d5f1fd5df8bc110c5ed8103c8a4756dd9dd0.tar.gz
(Really) updated to version 3.0.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce56f891d528..5297e41a9d6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,8 @@ pkgbase = rocthrust
makedepends = rocminfo
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-2.7.tar.gz
- sha256sums = 19ac24023a1015df19b29f3a8afcd61113ed91b26a7d3fa33b00a1f742e51be1
+ source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/3.0.0.tar.gz
+ sha256sums = 42fc7953e1b230a387851918cfd2490ac3d520f43f068d45fc348015196cabd8
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 2be4fedcac92..9d3e9db260e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@ url="https://github.com/ROCmSoftwarePlatform/rocThrust"
license=('NCSAOSL')
depends=(hcc hip)
makedepends=(git cmake gcc ninja hcc python2 rocminfo)
-srcver="2.7"
-source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-$srcver.tar.gz")
-sha256sums=("19ac24023a1015df19b29f3a8afcd61113ed91b26a7d3fa33b00a1f742e51be1")
+srcver="3.0.0"
+source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/$srcver.tar.gz")
+sha256sums=("42fc7953e1b230a387851918cfd2490ac3d520f43f068d45fc348015196cabd8")
build() {
mkdir -p "$srcdir/build"
@@ -33,7 +33,7 @@ build() {
-DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/rocthrust" \
-DBUILD_TEST=OFF \
-G Ninja \
- "$srcdir/rocThrust-rocm-$srcver"
+ "$srcdir/rocThrust-$srcver"
ninja
}