summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaetherm2020-01-09 07:32:51 +0100
committernaetherm2020-01-09 07:32:51 +0100
commit882b289a5d1875bd0732b56892f6bc088ec0e1d2 (patch)
treebd5898d4aee3aa1daf34e095d94d769223a0f4b6
parentbc5c2a30091a02b49a6e767be791dee5f636fb91 (diff)
downloadaur-882b289a5d1875bd0732b56892f6bc088ec0e1d2.tar.gz
Updated to version 3.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65b122e47825..ce56f891d528 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm.
- pkgver = 2.6.0
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/rocThrust
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = rocthrust
makedepends = rocminfo
depends = hcc
depends = hip
- source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/2.6.0.tar.gz
- sha256sums = 1252f56cc91040d5be7a816a9e3623ba968c40ef61706173813fcf2af4832d7e
+ source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-2.7.tar.gz
+ sha256sums = 19ac24023a1015df19b29f3a8afcd61113ed91b26a7d3fa33b00a1f742e51be1
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 9fffee30335c..2be4fedcac92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=2.6.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="Port of the Thrust parallel algorithm library atop HIP/ROCm."
arch=('x86_64')
@@ -8,9 +8,9 @@ url="https://github.com/ROCmSoftwarePlatform/rocThrust"
license=('NCSAOSL')
depends=(hcc hip)
makedepends=(git cmake gcc ninja hcc python2 rocminfo)
-srcver="2.6.0"
-source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/$srcver.tar.gz")
-sha256sums=("1252f56cc91040d5be7a816a9e3623ba968c40ef61706173813fcf2af4832d7e")
+srcver="2.7"
+source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-$srcver.tar.gz")
+sha256sums=("19ac24023a1015df19b29f3a8afcd61113ed91b26a7d3fa33b00a1f742e51be1")
build() {
mkdir -p "$srcdir/build"
@@ -31,8 +31,9 @@ build() {
# TODO: fix librocthrust.so, it contains references to $srcdir
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="$pkgdir/opt/rocm/rocthrust" \
+ -DBUILD_TEST=OFF \
-G Ninja \
- "$srcdir/rocThrust-$srcver"
+ "$srcdir/rocThrust-rocm-$srcver"
ninja
}