summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2020-05-15 14:12:14 +0200
committerGitHub2020-05-15 08:12:14 -0400
commitaeacfe610fe9aa92917a4b3f321eda0d682fd193 (patch)
tree06f987149581d06945c426e8785971d54d7856c5
parent857d1869fa0ff5057aa9e93add5bafe959128c5b (diff)
downloadaur-aeacfe610fe9aa92917a4b3f321eda0d682fd193.tar.gz
[rocthrust] Successful build in clean chroot (#149)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 21 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d53f665ba7e..23e904559e44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = rocthrust
- pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm.
+ pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm
pkgver = 3.3.0
- pkgrel = 3
- url = https://github.com/ROCmSoftwarePlatform/rocThrust
+ pkgrel = 4
+ url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust
arch = x86_64
- license = custom:NCSAOSL
+ license = Apache
makedepends = cmake
+ makedepends = git
makedepends = hcc
- makedepends = python2
- makedepends = rocminfo
- makedepends = comgr
- depends = hcc
- depends = hip
- source = https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-3.3.0.tar.gz
+ depends = hip-hcc
+ depends = rocprim
+ source = rocthrust-3.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-3.3.0.tar.gz
sha256sums = 5782c9b96233b2050168381b3c2259baeb410b859f68c25b2d14110fb1bb726f
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 570c7ab6d2bb..9227ac7bd53b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,26 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
pkgver=3.3.0
-pkgrel=3
-pkgdesc="Port of the Thrust parallel algorithm library atop HIP/ROCm."
+pkgrel=4
+pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
arch=('x86_64')
-url="https://github.com/ROCmSoftwarePlatform/rocThrust"
-license=('custom:NCSAOSL')
-depends=('hcc' 'hip')
-makedepends=('cmake' 'hcc' 'python2' 'rocminfo' 'comgr')
-source=("https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-$pkgver.tar.gz")
+url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust'
+license=('Apache')
+depends=('hip-hcc' 'rocprim')
+makedepends=('cmake' 'git' 'hcc')
+_git='https://github.com/ROCmSoftwarePlatform/rocThrust'
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
sha256sums=('5782c9b96233b2050168381b3c2259baeb410b859f68c25b2d14110fb1bb726f')
build() {
- mkdir -p "$srcdir/build"
- cd "$srcdir/build"
-
- # Tensile library needs python to be python2
- export PATH="$srcdir:$PATH"
- [[ -e "$srcdir/python" ]] || ln -s /usr/bin/python2 "$srcdir/python"
-
- # fix broken build with stack protection
- export CFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CFLAGS")"
- export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
- export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
-
- # compile with HCC
- export CXX="/opt/rocm/hcc/bin/hcc"
+ mkdir -p build
+ cd build
- # TODO: fix librocthrust.so, it contains references to $srcdir
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocthrust \
- -DBUILD_TEST=OFF \
+ CXX=/opt/rocm/hcc/bin/hcc \
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/rocthrust \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
+ -DBUILD_TEST=OFF \
"$srcdir/rocThrust-rocm-$pkgver"
- make
}
package() {
@@ -41,11 +28,6 @@ package() {
make DESTDIR="$pkgdir" install
- install -d "$pkgdir/etc/ld.so.conf.d"
- cat << EOF > "$pkgdir/etc/ld.so.conf.d/rocthrust.conf"
-/opt/rocm/rocthrust/lib
-EOF
-
install -d "$pkgdir/opt/rocm/include"
ln -s /opt/rocm/rocthrust/include/thrust "$pkgdir/opt/rocm/include"
}