summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-11-10 16:34:23 +0100
committerTorsten Keßler2021-11-10 16:34:23 +0100
commitd54a419843dd517f3e173a4c319569adde978b07 (patch)
tree53fc9593005ee9cbeca43205f109ab98c5510011
parent472e91e200d8bf1162b0b51026ed6a5ddaab973b (diff)
downloadaur-d54a419843dd517f3e173a4c319569adde978b07.tar.gz
upgpkg: rocthrust 4.5.0-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f7cf4ad3d3e..3cf045892fa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm
- pkgver = 4.3.1
+ pkgver = 4.5.0
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust
arch = x86_64
license = Apache
makedepends = cmake
+ makedepends = rocm-cmake
makedepends = git
- depends = hip-rocclr
+ depends = hip
depends = rocprim
- source = rocthrust-4.3.1.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-4.3.1.tar.gz
- sha256sums = 86fcd3bc275efe9a485aed48afdc6d3351804c076caee43e3fb8bd69752865e9
+ source = rocthrust-4.5.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-4.5.0.tar.gz
+ sha256sums = 86cf897b01a6f5df668d978ce42d44a6ae9df9f8adc92d0a1a49a7c3bbead259
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index 70bdbc7482e8..abaa9a4f7f9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=4.3.1
+pkgver=4.5.0
pkgrel=1
pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust'
license=('Apache')
-depends=('hip-rocclr' 'rocprim')
-makedepends=('cmake' 'git')
+depends=('hip' 'rocprim')
+makedepends=('cmake' 'rocm-cmake' 'git')
_git='https://github.com/ROCmSoftwarePlatform/rocThrust'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('86fcd3bc275efe9a485aed48afdc6d3351804c076caee43e3fb8bd69752865e9')
+sha256sums=('86cf897b01a6f5df668d978ce42d44a6ae9df9f8adc92d0a1a49a7c3bbead259')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.3.x/docs/markdown/clang_options.md
-
- # With version 3.21, HIP support was added to CMake that breaks the current scripts, see
- # https://github.com/ROCmSoftwarePlatform/rocRAND/issues/198#issuecomment-893573440
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.5.x/docs/markdown/clang_options.md
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
- -D__skip_rocmclang=ON \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
-DBUILD_TEST=OFF