summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-04-03 09:38:34 +0200
committerTorsten Keßler2022-04-03 09:38:34 +0200
commitf5f97b931ddc6f106186a6df5d84e65a2cf3c090 (patch)
tree0f27a9c9bfa1f18d8cdf8831fc258bd51ad81819
parent8a2eeabed43bfdb5120799a00b11e022d76216d1 (diff)
downloadaur-f5f97b931ddc6f106186a6df5d84e65a2cf3c090.tar.gz
upgpkg: rocthrust 5.1.0-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abf608012dae..b4a85d1f78f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocthrust
pkgdesc = Port of the Thrust parallel algorithm library atop HIP/ROCm
- pkgver = 5.0.2
+ pkgver = 5.1.0
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocthrust
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = rocthrust
makedepends = git
depends = hip
depends = rocprim
- source = rocthrust-5.0.2.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-5.0.2.tar.gz
- sha256sums = 60f0cf1848cc7cd8663f15307bd695eee3c5b20d3ad3baa4bc696189ffdcfd53
+ source = rocthrust-5.1.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocThrust/archive/rocm-5.1.0.tar.gz
+ sha256sums = fee779ae3d55b97327d87beca784fc090fa02bc95238d9c3bf3021e266e73979
pkgname = rocthrust
diff --git a/PKGBUILD b/PKGBUILD
index cb8f28a0228f..12809fa1c265 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocthrust
-pkgver=5.0.2
+pkgver=5.1.0
pkgrel=1
pkgdesc='Port of the Thrust parallel algorithm library atop HIP/ROCm'
arch=('x86_64')
@@ -11,12 +11,12 @@ depends=('hip' 'rocprim')
makedepends=('cmake' 'rocm-cmake' 'git')
_git='https://github.com/ROCmSoftwarePlatform/rocThrust'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('60f0cf1848cc7cd8663f15307bd695eee3c5b20d3ad3baa4bc696189ffdcfd53')
+sha256sums=('fee779ae3d55b97327d87beca784fc090fa02bc95238d9c3bf3021e266e73979')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.0.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.1.x/docs/markdown/clang_options.md
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \