summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkaptoxic2015-11-24 05:11:26 -0500
committerkaptoxic2015-11-24 05:11:26 -0500
commitbe30c230fdc757b51678d99b1eacefd7d9675214 (patch)
tree7e13f8b19ddfcf4c7945081be3a70eddc7d1bc69
downloadaur-be30c230fdc757b51678d99b1eacefd7d9675214.tar.gz
Revive original package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
-rw-r--r--rodin.profile1
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee6a87302ffc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = rodin
+ pkgdesc = Open tool platform for the cost effective rigorous development of dependable complex software systems services.
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = http://www.event-b.org
+ arch = i686
+ arch = x86_64
+ license = CPL
+ license = EPL
+ depends = python
+ depends = libxrender
+ depends = fontconfig
+ depends = java-runtime
+ source = rodin.profile
+ source = http://downloads.sourceforge.net/project/rodin-b-sharp/Core_Rodin_Platform/3.0.1/rodin-3.0.1.201406111447-5326174-linux.gtk.x86.tar.gz
+ md5sums = c9fcb488308b15325449384d0fe9c411
+ md5sums = 7f52140cc41133908b19ed8758d9b80b
+ sha256sums = 69193f15dabda1ee69b45744a22f0306f67793e71b629befcbd3e27c93ff5b8e
+ sha256sums = ede945b0abde3c1167d77f1cedba15c2234671a4c8e3e65cfbfd487fad0dee2a
+
+pkgname = rodin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f28ab1d378e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Gustavo A. Gomez Farhat <gustavo_dot_gomez_dot_farhat at gmail_dot_com>
+
+pkgname=rodin
+pkgver=3.0.1
+pkgver_upstream=201406111447-5326174
+pkgrel=1
+pkgdesc="Open tool platform for the cost effective rigorous development of dependable complex software systems services."
+arch=('i686' 'x86_64')
+url="http://www.event-b.org"
+license=('CPL' 'EPL')
+depends=('python' 'libxrender' 'fontconfig' 'java-runtime')
+source=(rodin.profile)
+md5sums=('c9fcb488308b15325449384d0fe9c411')
+sha256sums=('69193f15dabda1ee69b45744a22f0306f67793e71b629befcbd3e27c93ff5b8e')
+
+if test "$CARCH" == x86_64; then
+ source+=(http://downloads.sourceforge.net/project/rodin-b-sharp/Core_Rodin_Platform/${pkgver}/rodin-${pkgver}.${pkgver_upstream}-linux.gtk.x86_64.tar.gz)
+ md5sums+=('386e1b1a3d3e343f624e4cdda6719630')
+ sha256sums+=('acbcfa9c1f9619862c20b7275eef1fdf33c54132ce2c307061867ed3bd255c13')
+else
+ source+=(http://downloads.sourceforge.net/project/rodin-b-sharp/Core_Rodin_Platform/${pkgver}/rodin-${pkgver}.${pkgver_upstream}-linux.gtk.x86.tar.gz)
+ md5sums+=('7f52140cc41133908b19ed8758d9b80b')
+ sha256sums+=('ede945b0abde3c1167d77f1cedba15c2234671a4c8e3e65cfbfd487fad0dee2a')
+fi
+
+package() {
+ cd $srcdir/$pkgname
+ mkdir -p $pkgdir/opt/rodin || return 1
+ cp -rf * $pkgdir/opt/rodin || return 1
+ install -m 755 -D $srcdir/rodin.profile $pkgdir/etc/profile.d/rodin.sh
+}
diff --git a/rodin.profile b/rodin.profile
new file mode 100644
index 000000000000..31e5a61ec1d5
--- /dev/null
+++ b/rodin.profile
@@ -0,0 +1 @@
+export PATH=${PATH}:/opt/rodin