summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorleadseason2024-02-12 19:09:53 +0200
committerleadseason2024-02-12 19:09:53 +0200
commit50605e6b4c6db2ef0b90b3ceeab2746b94e0dce5 (patch)
tree82a047f06ae75030cd6107440fca0c28a6c057b0
downloadaur-50605e6b4c6db2ef0b90b3ceeab2746b94e0dce5.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69bc3dba0fb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rofi-emoji-git
+ pkgdesc = A Rofi plugin for selecting emojis
+ pkgver = r73.7f68772
+ pkgrel = 1
+ url = https://github.com/Mange/rofi-emoji
+ arch = x86_64
+ license = MIT
+ checkdepends = check
+ depends = rofi
+ optdepends = xsel: X11 support
+ optdepends = xclip: X11 support
+ optdepends = wl-clipboard: Wayland support
+ conflicts = rofi-emoji
+ source = git+https://github.com/Mange/rofi-emoji
+ b2sums = SKIP
+
+pkgname = rofi-emoji-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4273195a6d6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Leadseason <admin@leadseason.eu>
+
+pkgname=rofi-emoji-git
+_pkgname=rofi-emoji
+pkgver=r73.7f68772
+pkgrel=1
+pkgdesc='A Rofi plugin for selecting emojis'
+url='https://github.com/Mange/rofi-emoji'
+arch=('x86_64')
+license=('MIT')
+depends=('rofi')
+checkdepends=('check')
+optdepends=(
+ 'xsel: X11 support'
+ 'xclip: X11 support'
+ 'wl-clipboard: Wayland support'
+)
+makedepnds=(
+ "git"
+ "autoconf"
+ "automake"
+ "libtool"
+)
+conflicts=(${_pkgname})
+source=(git+https://github.com/Mange/${_pkgname})
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${_pkgname}
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd ${_pkgname}
+ make check
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}/" install
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: