summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Ford2020-10-03 22:31:37 +0100
committerOliver Ford2020-10-03 22:31:37 +0100
commit7f618325236357b5fc2dc890925813ff4d5803b3 (patch)
tree551fd0196f61423143bd00b782432f1b31dc70e9
parent63ef1a94454dde57220e9a533767637ac7d067e8 (diff)
downloadaur-7f618325236357b5fc2dc890925813ff4d5803b3.tar.gz
Turn AUR remote into packaging-only fork
Seems you're really not supposed to have PKGBUILD in the project's own repo - subdirectory's not allowed etc. I'll keep it, but fork AUR's version here, and then treat it as if a different project entirely from a releasing perspective.
-rw-r--r--LICENSE29
-rw-r--r--README.md18
-rwxr-xr-xrofi-gh-issues38
3 files changed, 0 insertions, 85 deletions
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 663eefb2e131..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,29 +0,0 @@
-BSD 3-Clause License
-
-Copyright (c) 2020, Oliver Ford
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
-1. Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
-
-2. Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-3. Neither the name of the copyright holder nor the names of its
- contributors may be used to endorse or promote products derived from
- this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/README.md b/README.md
deleted file mode 100644
index d8ccecefefcb..000000000000
--- a/README.md
+++ /dev/null
@@ -1,18 +0,0 @@
-# rofi-gh
-
-Allows you to get GitHub in [rofi](//github.com/davatorium/rofi).
-
- - List issues in your repositories and open them (`rofi-gh-issues`)
- - Looking for something else? Issues & PRs welcome :)
-
-## Usage
-
-Ensure the scripts you wish to use are somewhere on your `$PATH` (for example, `/usr/local/bin/rofi-gh-issues`) and run `rofi -show '<prompt>:<script>'` (`rofi -show 'GH:rofi-gh-issues'`).
-
-### rofi-gh-issues
-
-This one was my initial motivation for `rofi-gh`, so that I could sit down in the mood to work on something, but with nothing particular in mind, and see what issues I have open in my repositories. For that reason, the default (and presently only) query is:
-
- - [`user:@me is:open`](//github.com/issues?q=user%3A%40me+is%3Aopen) (default)
-
-But I'm certainly open to adding configuration if you have other use-cases/desires (open an issue or PR).
diff --git a/rofi-gh-issues b/rofi-gh-issues
deleted file mode 100755
index fa717058108c..000000000000
--- a/rofi-gh-issues
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/bash
-set -Ee
-set -u
-set -o pipefail
-
-issuesjson="${XDG_CACHE_HOME:-$HOME/.cache}/rofi-gh-issues/issues.json"
-mkdir -p "$(dirname "$issuesjson")"
-
-initial_call_list() {
- gh api search/issues -X GET -f q='user:@me is:open' \
- | jq '.items | map({url:.html_url, display:("[" + (.repository_url | split("/"))[-1] + "] " + .title)})' \
- | tee "$issuesjson" \
- | jq -r 'map(.display)[]' \
- ;
- return 0
-}
-
-selected_entry() {
- selection="$1"
- jq -r ".[] | select(.display==\"$selection\").url" "$issuesjson" \
- | xargs xdg-open \
- ;
- return 0
-}
-
-case "$ROFI_RETV" in
- 0)
- initial_call_list
- exit "$?"
- ;;
- 1)
- selected_entry "$1"
- exit "$?"
- ;;
- *)
- exit 2
- ;;
-esac