summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororestisf2017-06-18 15:12:36 +0300
committerorestisf2017-06-18 15:12:36 +0300
commit568bd9cda5d0362c07bc40ffdde993bf7885fbfc (patch)
tree9d537b58bd7e5259dee4804469d65e066a614749
parent248e2b7682d06a9e589f629099d778336c189471 (diff)
downloadaur-568bd9cda5d0362c07bc40ffdde993bf7885fbfc.tar.gz
Update for meson build
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD79
2 files changed, 72 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fea7ae55ad2c..6e4e0ca66a52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
# Generated by mksrcinfo v8
-# Sun Jun 26 17:44:16 UTC 2016
+# Sun Jun 18 12:07:31 UTC 2017
pkgbase = rofi-git
pkgdesc = A window switcher, run dialog and dmenu replacement
- pkgver = 1.1.0.r30.g4af6976
+ pkgver = 1.3.1.r644.g10e6c333
pkgrel = 1
url = https://davedavenport.github.io/rofi/
arch = i686
arch = x86_64
license = MIT
+ makedepends = check
makedepends = git
- depends = libx11
- depends = libxft
+ makedepends = meson
+ depends = cairo
depends = freetype2
- depends = libxdg-basedir
- depends = pango
- depends = startup-notification
+ depends = librsvg
+ depends = libx11
depends = libxcb
+ depends = libxdg-basedir
+ depends = libxft
depends = libxkbcommon
depends = libxkbcommon-x11
+ depends = pango
+ depends = startup-notification
depends = xcb-util
depends = xcb-util-wm
depends = xcb-util-xrm
@@ -25,7 +29,11 @@ pkgbase = rofi-git
provides = rofi
conflicts = rofi
source = git+https://github.com/DaveDavenport/rofi
- md5sums = SKIP
+ source = git+https://github.com/sardemff7/libgwater
+ source = git+https://github.com/sardemff7/libnkutils
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = rofi-git
diff --git a/PKGBUILD b/PKGBUILD
index 59e150d86ae2..56fb95c85d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,83 @@
-# Maintainer: Benjamin Chrétien <chretien+aur [at] lirmm [dot] fr>
+# Contributor: Benjamin Chrétien <chretien+aur [at] lirmm [dot] fr>
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: Rasi <rasi@xssn.at>
# Contributor: Sean Pringle <sean.pringle@gmail.com>
# Contributor: SanskritFritz (gmail)
+# Contributor: Dan Beste <dan.ray.beste@gmail.com>
pkgname=rofi-git
_gitname=rofi
-pkgver=1.1.0.r30.g4af6976
+pkgver=1.3.1.r644.g10e6c333
pkgrel=1
-pkgdesc="A window switcher, run dialog and dmenu replacement"
+pkgdesc='A window switcher, run dialog and dmenu replacement'
arch=('i686' 'x86_64')
-url="https://davedavenport.github.io/rofi/"
+url='https://davedavenport.github.io/rofi/'
license=('MIT')
-depends=(libx11 libxft freetype2 libxdg-basedir pango startup-notification
- libxcb libxkbcommon libxkbcommon-x11 xcb-util xcb-util-wm xcb-util-xrm)
+depends=(
+ 'cairo' 'freetype2' 'librsvg' 'libx11' 'libxcb' 'libxdg-basedir'
+ 'libxft' 'libxkbcommon' 'libxkbcommon-x11' 'pango'
+ 'startup-notification' 'xcb-util' 'xcb-util-wm' 'xcb-util-xrm'
+)
optdepends=('i3-wm: use as a window switcher')
-makedepends=('git')
+makedepends=('check' 'git' 'meson')
provides=('rofi')
conflicts=('rofi')
-source=("git+https://github.com/DaveDavenport/rofi")
-md5sums=('SKIP')
+source=(
+ 'git+https://github.com/DaveDavenport/rofi'
+ 'git+https://github.com/sardemff7/libgwater'
+ 'git+https://github.com/sardemff7/libnkutils'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd "$_gitname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_gitname"
+
+ git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$_gitname"
- git submodule update --init
- autoreconf --install
+ cd "${_gitname}"
+
+ for subproject in libgwater libnkutils; do
+ local submodule="subprojects/${subproject}"
+ git submodule init "${submodule}"
+ git config "submodule.${submodule}.url" "${srcdir}/${subproject}"
+ git submodule update "${submodule}"
+ done
- # Default compiler = clang, which can be a problem if using hardening-wrapper
- CC=gcc ./configure --prefix=/usr
+ if [[ -d build ]]; then
+ # This should be removed when 'meson [OPTIONS] ..' can be run
+ # repeatedly without generating an error.
+ rm -rf build
+ fi
+ mkdir -p build
}
build() {
- cd "$srcdir/$_gitname"
- make
+ cd "${_gitname}/build"
+
+ meson --prefix=/usr ..
+ ninja
+}
+
+check() {
+ cd "${_gitname}/build"
+
+ ninja test
}
package() {
- cd "$srcdir/$_gitname"
- make install install-man DESTDIR="$pkgdir"
+ cd "${_gitname}/build"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/rofi/COPYING"
- install -dm755 "$pkgdir/usr/share/doc/rofi/examples"
- install -Dm755 Examples/*.sh "$pkgdir/usr/share/doc/rofi/examples"
+ DESTDIR="${pkgdir}" ninja install
+ install -d -m 755 "${pkgdir}/usr/share/doc/rofi/examples"
+ install -d -m 755 "${pkgdir}/usr/share/man/man1"
+ install -D -m 644 ../COPYING "$pkgdir/usr/share/licenses/rofi/COPYING"
+ install -D -m 644 ../doc/*.1 "${pkgdir}/usr/share/man/man1/"
+ install -D -m 755 ../Examples/*.sh "$pkgdir/usr/share/doc/rofi/examples"
}