summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-01-11 21:36:45 +0100
committerwillemw122023-01-11 21:36:45 +0100
commit7a15e920185670df43e1e93a58d33db49e8ae86c (patch)
tree638097640f42ac70ecb5416b90c4f55769175751
parent825212cf11ca68ac5910569cd8e1e0b8603616c9 (diff)
downloadaur-7a15e920185670df43e1e93a58d33db49e8ae86c.tar.gz
Update git submodules download. Added aarch64
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30cabdecf345..cc860311aaec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = rofi-lbonn-wayland-git
pkgdesc = A window switcher, application launcher and dmenu replacement (fork with Wayland support)
- pkgver = 1.7.3.wayland1.r51.g1e8c22b4
+ pkgver = 1.7.5.wayland1.r42.g5d4a3e14
pkgrel = 1
url = https://github.com/lbonn/rofi
arch = x86_64
+ arch = aarch64
license = MIT
makedepends = git
makedepends = meson
@@ -21,6 +22,10 @@ pkgbase = rofi-lbonn-wayland-git
provides = rofi
conflicts = rofi
source = rofi-lbonn-wayland-git::git+https://github.com/lbonn/rofi.git#branch=wayland
+ source = git+https://github.com/sardemff7/libgwater.git
+ source = git+https://github.com/sardemff7/libnkutils.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = rofi-lbonn-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
index 7a57c48d5e05..9f7e4af50d1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@
# Contributor: SanskritFritz (gmail)
pkgname=rofi-lbonn-wayland-git
-pkgver=1.7.3.wayland1.r51.g1e8c22b4
+pkgver=1.7.5.wayland1.r42.g5d4a3e14
pkgrel=1
pkgdesc='A window switcher, application launcher and dmenu replacement (fork with Wayland support)'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url='https://github.com/lbonn/rofi'
license=(MIT)
depends=('check' 'librsvg' 'libxdg-basedir' 'libxkbcommon-x11' 'startup-notification'
@@ -22,15 +22,20 @@ makedepends=('git' 'meson' 'wayland-protocols')
optdepends=('i3-wm: use as a window switcher')
provides=('rofi')
conflicts=('rofi')
-source=("$pkgname::git+$url.git#branch=wayland")
-sha256sums=('SKIP')
+source=("$pkgname::git+$url.git#branch=wayland"
+ "git+https://github.com/sardemff7/libgwater.git"
+ "git+https://github.com/sardemff7/libnkutils.git")
+sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
git -C $pkgname describe --long | sed 's/\([^-]*-g\)/r\1/;s/[-+]/./g'
}
prepare() {
- git -C $pkgname submodule update --init
+ git -C $pkgname submodule init
+ git -C $pkgname config submodule.externals/vendor/libgwater.url "$srcdir/libgwater"
+ git -C $pkgname config submodule.externals/vendor/libnkutils.url "$srcdir/libnkutils"
+ git -C $pkgname -c protocol.file.allow=always submodule update
}
build() {