summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122022-07-12 13:42:38 +0200
committerwillemw122022-07-12 13:42:38 +0200
commit825212cf11ca68ac5910569cd8e1e0b8603616c9 (patch)
tree87596c9285718a78645717991be791db3dd13876
parentc203814467b2fe4e8abd488759f5780ea59ba38d (diff)
downloadaur-825212cf11ca68ac5910569cd8e1e0b8603616c9.tar.gz
Minor edits
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 26 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f37400eaf42..30cabdecf345 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = rofi-lbonn-wayland-git
- pkgdesc = A window switcher, application launcher and dmenu replacement (Wayland fork)
- pkgver = 1.7.0.wayland1.r2.g197611e7
+ pkgdesc = A window switcher, application launcher and dmenu replacement (fork with Wayland support)
+ pkgver = 1.7.3.wayland1.r51.g1e8c22b4
pkgrel = 1
url = https://github.com/lbonn/rofi
arch = x86_64
license = MIT
- makedepends = check
makedepends = git
makedepends = meson
makedepends = wayland-protocols
+ depends = check
+ depends = librsvg
depends = libxdg-basedir
- depends = startup-notification
depends = libxkbcommon-x11
+ depends = startup-notification
+ depends = wayland
depends = xcb-util-cursor
depends = xcb-util-wm
depends = xcb-util-xrm
- depends = librsvg
- depends = wayland
optdepends = i3-wm: use as a window switcher
provides = rofi
conflicts = rofi
- source = rofi::git+https://github.com/lbonn/rofi.git#branch=wayland
+ source = rofi-lbonn-wayland-git::git+https://github.com/lbonn/rofi.git#branch=wayland
sha256sums = SKIP
pkgname = rofi-lbonn-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
index 273184d474d6..7a57c48d5e05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: tinywrkb <tinywrkb@gmail.com>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: tinywrkb <tinywrkb@gmail.com>
# Contributor: Morten Linderud <foxboron@archlinux.org>
# Contributor: Maxim Baz <rofi at maximbaz dot com>
# Contributor: Anatol Pomozov
@@ -9,37 +10,33 @@
# Contributor: SanskritFritz (gmail)
pkgname=rofi-lbonn-wayland-git
-pkgver=1.7.0.wayland1.r2.g197611e7
+pkgver=1.7.3.wayland1.r51.g1e8c22b4
pkgrel=1
-pkgdesc='A window switcher, application launcher and dmenu replacement (Wayland fork)'
-arch=(x86_64)
+pkgdesc='A window switcher, application launcher and dmenu replacement (fork with Wayland support)'
+arch=('x86_64')
url='https://github.com/lbonn/rofi'
license=(MIT)
-depends=(libxdg-basedir startup-notification libxkbcommon-x11 xcb-util-cursor xcb-util-wm
- xcb-util-xrm librsvg wayland)
-makedepends=(check git meson wayland-protocols)
+depends=('check' 'librsvg' 'libxdg-basedir' 'libxkbcommon-x11' 'startup-notification'
+ 'wayland' 'xcb-util-cursor' 'xcb-util-wm' 'xcb-util-xrm')
+makedepends=('git' 'meson' 'wayland-protocols')
optdepends=('i3-wm: use as a window switcher')
-provides=(rofi)
-conflicts=(rofi)
-source=("rofi::git+https://github.com/lbonn/rofi.git#branch=wayland")
+provides=('rofi')
+conflicts=('rofi')
+source=("$pkgname::git+$url.git#branch=wayland")
sha256sums=('SKIP')
pkgver() {
- cd rofi
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/[-+]/./g'
+ git -C $pkgname describe --long | sed 's/\([^-]*-g\)/r\1/;s/[-+]/./g'
}
prepare() {
- cd rofi
- git submodule update --init
+ git -C $pkgname submodule update --init
}
build() {
- local meson_options=(
- -D wayland=enabled
- -D check=enabled
- )
- arch-meson rofi build "${meson_options[@]}"
+ local meson_options=(-Dwayland=enabled -Dcheck=enabled)
+
+ arch-meson $pkgname build "${meson_options[@]}"
meson compile -C build
}
@@ -50,7 +47,7 @@ check() {
package() {
meson install -C build --destdir="$pkgdir"
- cd rofi
- install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname/ COPYING
- install -Dm755 -t "$pkgdir"/usr/share/doc/rofi/examples/ Examples/*.sh
+ install -Dm644 $pkgname/COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm755 $pkgname/Examples/*.sh -t "$pkgdir/usr/share/doc/rofi/examples/"
}
+