summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorearthian2024-02-19 03:35:34 +0300
committerearthian2024-02-19 03:40:22 +0300
commit97d56c57dafb8039c9749a16e8295a2c4ab59888 (patch)
tree0f6daab892b1b65d40d8e31063a759af8705a1bd
downloadaur-97d56c57dafb8039c9749a16e8295a2c4ab59888.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5eedea17308f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = rofi-pass-wayland-git
+ pkgdesc = Rofi-wayland frontend for ZX2C4 pass project.
+ pkgver = v2.1.0.r14.g946b1ff
+ pkgrel = 1
+ url = https://github.com/Seme4eg/rofi-pass-wayland
+ arch = any
+ license = GPL-3.0-or-later
+ makedepends = git
+ depends = rofi-lbonn-wayland-git
+ depends = pass
+ depends = wtype
+ depends = wl-clipboard
+ optdepends = qrencode: qrcode functionality
+ optdepends = pass-otp: one time passwords generation
+ provides = rofi-pass-wayland=v2.1.0
+ conflicts = rofi-pass-wayland
+ conflicts = rofi-pass-git
+ conflicts = rofi-pass-ydotool-git
+ source = git+https://github.com/Seme4eg/rofi-pass-wayland
+ sha256sums = SKIP
+
+pkgname = rofi-pass-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e58ca97928f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: earthian <418@duck.com>
+
+pkgname=rofi-pass-wayland-git
+pkgver=v2.1.0.r14.g946b1ff
+pkgrel=1
+pkgdesc="Rofi-wayland frontend for ZX2C4 pass project."
+arch=('any')
+url="https://github.com/Seme4eg/rofi-pass-wayland"
+license=('GPL-3.0-or-later')
+depends=('rofi-lbonn-wayland-git' 'pass' 'wtype' 'wl-clipboard')
+optdepends=('qrencode: qrcode functionality'
+ 'pass-otp: one time passwords generation')
+makedepends=('git')
+provides=("${pkgname%-git}=${pkgver%%.r*}")
+conflicts=("${pkgname%-git}" 'rofi-pass-git' 'rofi-pass-ydotool-git')
+source=('git+https://github.com/Seme4eg/rofi-pass-wayland')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --abbrev=7 | sed 's/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}