summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Artyushkevich2022-02-01 00:36:28 +0300
committerAnton Artyushkevich2022-02-01 00:36:28 +0300
commitb88d0dc93e76fb2e343e23e4551c920e5815328c (patch)
treec38f56927b9f56ae39fd6f6b1f3267f50c4e8ed2
downloadaur-b88d0dc93e76fb2e343e23e4551c920e5815328c.tar.gz
version 1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4187e7da272
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rofi-power-menu-git
+ pkgdesc = Configurable power menu mode for Rofi and dmenu
+ pkgver = r37.368ba43
+ pkgrel = 1
+ url = https://github.com/jluttine/rofi-power-menu
+ arch = any
+ license = MIT
+ depends = rofi
+ optdepends = rofi-script-to-dmenu: Run rofi scripts with dmenu (or with dmenu mode of rofi)
+ optdepends = dmenu: Use with dmenu instead of rofi
+ provides = dmenu-power-menu
+ source = git+https://github.com/jluttine/rofi-power-menu
+ sha256sums = SKIP
+
+pkgname = rofi-power-menu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b16543515dc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: tyusha <htovver@gmail.com>
+pkgname=rofi-power-menu-git
+pkgver=r37.368ba43
+_name=rofi-power-menu
+pkgrel=1
+pkgdesc="Configurable power menu mode for Rofi and dmenu"
+arch=('any')
+url="https://github.com/jluttine/${_name}"
+license=('MIT')
+# If you want to use dmenu instead, and don't want to install rofi,
+# change this to dmenu and also install rofi-script-to-dmenu.
+# Full instructions in README/on GitHub.
+depends=('rofi')
+optdepends=('rofi-script-to-dmenu: Run rofi scripts with dmenu (or with dmenu mode of rofi)'
+ 'dmenu: Use with dmenu instead of rofi')
+provides=('dmenu-power-menu')
+source=("git+https://github.com/jluttine/${_name}")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/$_name"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/$_name" || exit 1
+ local doc_path="$pkgdir/usr/share/doc/${pkgname}"
+
+ install -Dm755 "rofi-power-menu" "$pkgdir/usr/bin/rofi-power-menu"
+ install -Dm755 "dmenu-power-menu" "$pkgdir/usr/bin/dmenu-power-menu"
+
+ install -Dm755 -d "${doc_path}"
+
+ install -Dm644 "README.md" "${doc_path}/README.md"
+ install -Dm644 "screenshot.png" "${doc_path}/screenshot.png"
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/${pkgname}/COPYING"
+}