summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoic Coyle2020-12-07 20:49:27 +0100
committerLoic Coyle2020-12-07 20:49:27 +0100
commit316612fd738b628b2972599701220e3256dcfcbf (patch)
treeb400c0ad644347a4c754e1b26e9d6f7429480f97
downloadaur-316612fd738b628b2972599701220e3256dcfcbf.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfc4b1d2ca04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rofi-ttv-git
+ pkgdesc = A script that uses rofi, youtube-dl and mpv to view twitch streams.
+ pkgver = r13.621edfe
+ pkgrel = 1
+ url = https://github.com/loiccoyle/rofi-ttv
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = curl
+ depends = jq
+ depends = rofi
+ depends = youtube-dl
+ depends = mpv
+ source = rofi-ttv::git+https://github.com/loiccoyle/rofi-ttv.git
+ md5sums = SKIP
+
+pkgname = rofi-ttv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41bfe9062e60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Loic Coyle <loic.coyle@hotmail.fr>
+
+_pkgname=rofi-ttv
+pkgname="${_pkgname}-git"
+pkgver=r13.621edfe
+pkgrel=1
+pkgdesc='A script that uses rofi, youtube-dl and mpv to view twitch streams.'
+arch=('any')
+url='https://github.com/loiccoyle/rofi-ttv'
+license=('MIT')
+depends=('curl' 'jq' 'rofi' 'youtube-dl' 'mpv')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/loiccoyle/rofi-ttv.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ install -D -m 755 -t "${pkgdir}/usr/bin/" rofi-ttv
+ install -D -m 644 -t "${pkgdir}/usr/share/licenses/${_pkgname}/" LICENSE
+}