summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2025-03-17 13:25:53 -0400
committerDaniel M. Capella2025-03-17 13:25:53 -0400
commit88b5d7900927a9c0e0ee73866518c95790495479 (patch)
treeed27a4591c7040902f1113f2af2a6017b2f6507a
parent1a68bb89cbeaa855f5dd06b46ed8a88f6125c1b3 (diff)
downloadaur-rofimoji-git.tar.gz
Switch to Hatchling from Poetry Core
https://github.com/fdw/rofimoji/commit/367533d76739492bb6df5ad94e200ece951cc6a4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a498b8538a29..50e41363f8e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = rofimoji-git
pkgdesc = Emoji, unicode and general character picker for rofi and rofi-likes
- pkgver = 6.2.0.r15.g473196a
+ pkgver = 6.5.0.r14.g167df25
pkgrel = 1
url = https://github.com/fdw/rofimoji
arch = any
license = MIT
makedepends = git
makedepends = python-build
+ makedepends = python-hatchling
makedepends = python-installer
- makedepends = python-poetry-core
depends = python-configargparse
optdepends = emoji-font: for the emojis character file
optdepends = nerd-fonts: for the nerd_font character file
diff --git a/PKGBUILD b/PKGBUILD
index 4ecc0a3d0f72..13339e81b871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=rofimoji-git
_name=${pkgname%-git}
-pkgver=6.2.0.r15.g473196a
+pkgver=6.5.0.r14.g167df25
pkgrel=1
pkgdesc='Emoji, unicode and general character picker for rofi and rofi-likes'
arch=(any)
@@ -12,8 +12,8 @@ depends=(python-configargparse)
makedepends=(
git
python-build
+ python-hatchling
python-installer
- python-poetry-core
)
optdepends=(
'emoji-font: for the emojis character file'
@@ -60,7 +60,7 @@ build() {
package() {
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
install -d "$pkgdir"/usr/share/licenses/$pkgname
- ln -s "$site_packages"/"$_name"-${pkgver%%.r*}.dist-info/LICENSE \
+ ln -s "$site_packages"/"$_name"-${pkgver%%.r*}.dist-info/licenses/LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
cd "$_name"