summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2021-02-20 18:13:43 -0500
committerDaniel M. Capella2021-02-20 18:13:43 -0500
commit2d1d1a726e784dbce3f66557b2b83390007f56da (patch)
treeb73c012f6e8eba216998704417d8dc9b3ed28475
parent2d38888959dd5eb9383f4aeaadd5579f5d448349 (diff)
downloadaur-2d1d1a726e784dbce3f66557b2b83390007f56da.tar.gz
Sync with stable package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--rofimoji-git.install2
3 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af8e8995a6d1..941a09423368 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = rofimoji-git
pkgdesc = Character picker for rofi
- pkgver = 4.3.0.r28.g4247a27
+ pkgver = 5.0.0.r0.gcf82f05
pkgrel = 1
url = https://github.com/fdw/rofimoji
install = rofimoji-git.install
arch = any
license = MIT
makedepends = git
- makedepends = python-pip
makedepends = python-setuptools
- makedepends = python-wheel
- depends = emoji-font
depends = python-configargparse
- depends = rofi
- optdepends = nerd-fonts: for the Nerd Fonts character file
- optdepends = wl-copy: for the Wayland clipboarder
- optdepends = wtype: for the Wayland typer
+ optdepends = emoji-font: for the emojis character file
+ optdepends = nerd-fonts: for the nerd_font character file
+ optdepends = rofi: for the X.Org selector
optdepends = xclip: for one of the X.Org clipboarders
optdepends = xsel: for one of the X.Org clipboarders
optdepends = xdotool: for the X.Org typer
+ optdepends = wofi: for the Wayland selector
+ optdepends = wl-copy: for the Wayland clipboarder
+ optdepends = wtype: for the Wayland typer
provides = rofimoji
conflicts = rofimoji
source = git+https://github.com/fdw/rofimoji.git
diff --git a/PKGBUILD b/PKGBUILD
index 97ac6a4529c1..a63ee1096bd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
pkgname=rofimoji-git
-pkgver=4.3.0.r28.g4247a27
+pkgver=5.0.0.r0.gcf82f05
pkgrel=1
pkgdesc='Character picker for rofi'
arch=('any')
url=https://github.com/fdw/rofimoji
license=('MIT')
-depends=('emoji-font' 'python-configargparse' 'rofi')
-makedepends=('git' 'python-pip' 'python-setuptools' 'python-wheel')
-optdepends=('nerd-fonts: for the Nerd Fonts character file'
- 'wl-copy: for the Wayland clipboarder'
- 'wtype: for the Wayland typer'
+depends=('python-configargparse')
+makedepends=('git' 'python-setuptools')
+optdepends=('emoji-font: for the emojis character file'
+ 'nerd-fonts: for the nerd_font character file'
+ 'rofi: for the X.Org selector'
'xclip: for one of the X.Org clipboarders'
'xsel: for one of the X.Org clipboarders'
- 'xdotool: for the X.Org typer')
+ 'xdotool: for the X.Org typer'
+ 'wofi: for the Wayland selector'
+ 'wl-copy: for the Wayland clipboarder'
+ 'wtype: for the Wayland typer')
provides=('rofimoji')
conflicts=('rofimoji')
install=$pkgname.install
@@ -28,12 +31,14 @@ pkgver() {
build() {
cd rofimoji
- python setup.py bdist_wheel
+ python setup.py build
}
package() {
cd rofimoji
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/*.whl
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
}
# vim:set ts=2 sw=2 et:
diff --git a/rofimoji-git.install b/rofimoji-git.install
index f4c2e22c7039..cf87c7ea3cc4 100644
--- a/rofimoji-git.install
+++ b/rofimoji-git.install
@@ -1,6 +1,6 @@
post_install() {
cat << EOF
-rofimoji requires that you have an appropriate "clipboarder" and "typer"
+rofimoji requires an appropriate "selector", "clipboarder", and "typer" to be
installed for your display server.
EOF
}