summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Meunier2020-07-08 11:50:40 +0200
committerGuillaume Meunier2020-07-08 11:50:40 +0200
commit504cc9cd6287c2e0857ad9b16720f56aa2d09978 (patch)
treeb1c4087203e586924d60f359e20ae2fa8e13a879
parentccfe4e6b80a280aa78bf5c7213183dbfddf40bc1 (diff)
downloadaur-504cc9cd6287c2e0857ad9b16720f56aa2d09978.tar.gz
Fix installation directory
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--install-dir.patch14
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f0877c8e796..a51939aa0e12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rog-core
pkgdesc = A utility for Linux to control many aspects (eventually) of the ASUS ROG laptops like the Zephyrus GX502GW
pkgver = 0.14.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/flukejones/rog-core
arch = x86_64
license = MPL2
@@ -10,7 +10,9 @@ pkgbase = rog-core
depends = dbus
depends = libusb
source = https://github.com/flukejones/rog-core/archive/v0.14.4.tar.gz
+ source = install-dir.patch
sha256sums = 8c89934545e82808805a7c1e43dd8c1f69177dbc14769be418bd8074bf18e1f8
+ sha256sums = 05222bde8ed64f96047f5d7c11a0bbd852ac8e518ddccb0e0cc9c83e661c173a
pkgname = rog-core
diff --git a/PKGBUILD b/PKGBUILD
index e7980d787267..d4b960e89797 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=rog-core
pkgbase=rog-core
pkgver=0.14.4
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="A utility for Linux to control many aspects (eventually) of the ASUS ROG laptops like the Zephyrus GX502GW"
arch=('x86_64')
@@ -19,13 +19,19 @@ options=()
install=
changelog=
-source=("https://github.com/flukejones/rog-core/archive/v$pkgver.tar.gz")
-sha256sums=('8c89934545e82808805a7c1e43dd8c1f69177dbc14769be418bd8074bf18e1f8')
+source=("https://github.com/flukejones/rog-core/archive/v$pkgver.tar.gz"
+ "install-dir.patch")
+sha256sums=('8c89934545e82808805a7c1e43dd8c1f69177dbc14769be418bd8074bf18e1f8'
+ '05222bde8ed64f96047f5d7c11a0bbd852ac8e518ddccb0e0cc9c83e661c173a')
noextract=()
validpgpkeys=()
+prepare()
+{
+ patch -d "$srcdir" -p1 < install-dir.patch
+}
+
build() {
- echo $srcdir
cd "$srcdir"/$pkgname-$pkgver
make
}
diff --git a/install-dir.patch b/install-dir.patch
new file mode 100644
index 000000000000..a8bc51847922
--- /dev/null
+++ b/install-dir.patch
@@ -0,0 +1,14 @@
+--- src/rog-core-0.14.4/Makefile 2020-07-07 10:50:09.000000000 +0200
++++ src/rog-core-0.14.4/Makefile 2020-07-08 11:45:59.863155274 +0200
+@@ -34,9 +34,9 @@
+
+ install: all
+ install -D -m 0755 "target/release/$(BIN)" "$(DESTDIR)$(bindir)/$(BIN)"
+- install -D -m 0644 "data/$(BIN).rules" "$(DESTDIR)/lib/udev/rules.d/99-$(BIN).rules"
++ install -D -m 0644 "data/$(BIN).rules" "$(DESTDIR)/usr/lib/udev/rules.d/99-$(BIN).rules"
+ install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(sysconfdir)/dbus-1/system.d/$(BIN).conf"
+- install -D -m 0644 "data/$(BIN).service" "$(DESTDIR)/lib/systemd/system/$(BIN).service"
++ install -D -m 0644 "data/$(BIN).service" "$(DESTDIR)/usr/lib/systemd/system/$(BIN).service"
+
+ uninstall:
+ rm -f "$(DESTDIR)$(bindir)/$(BIN)"