summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaansu2018-10-02 10:30:27 -0700
committerRaansu2018-10-02 10:30:27 -0700
commit7f6105b8e6a932f79877a504920dcc15efbb4111 (patch)
tree7a73e45a3102a409cfd9499555e1d4e389ced561
parentad259f9f234171422f6f82a0bca2f94442c1b5ea (diff)
downloadaur-7f6105b8e6a932f79877a504920dcc15efbb4111.tar.gz
Update PKGBUILD to build with QT5
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51d8a2f65335..e139abc01624 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = roger-wallet-git
pkgdesc = The Holy Roger Coin (ROGER), the leading altcoin derived from Litecoin. ROGER is developed with a focus on outing scams and trolling The Fake Roger.
- pkgver = 0.16.3.rogerv3r+0+g4fee9e4
+ pkgver = 0.16.3.rogerv3r+2+g21d2fb2c7
pkgrel = 1
url = https://theholyroger.com
arch = i686
@@ -9,24 +9,15 @@ pkgbase = roger-wallet-git
arch = armv7h
arch = aarch64
license = MIT
- makedepends = pkg-config
- makedepends = boost-libs
makedepends = boost
- makedepends = db4.8
- makedepends = gcc
- makedepends = gcc-libs
- makedepends = git
+ makedepends = libevent
+ makedepends = qt5-base
+ makedepends = qt5-tools
makedepends = qrencode
- makedepends = make
- makedepends = automoc4
- makedepends = automake
- makedepends = autoconf
- makedepends = libtool
+ makedepends = miniupnpc
+ makedepends = protobuf
makedepends = zeromq
- depends = qt4
- depends = miniupnpc
- depends = openssl
- depends = protobuf
+ makedepends = db4.8
provides = roger-wallet
provides = theholyroger
provides = theholyroger-qt
@@ -57,6 +48,7 @@ pkgname = theholyroger-daemon-git
depends = boost-libs
depends = libevent
depends = miniupnpc
+ depends = libminiupnpc.so
depends = zeromq
provides = theholyroger-daemon
conflicts = theholyroger-daemon
@@ -71,13 +63,14 @@ pkgname = theholyroger-cli-git
pkgname = theholyroger-qt-git
pkgdesc = The Holy Roger Coin (ROGER), the leading altcoin derived from Litecoin - Qt
depends = boost-libs
- depends = desktop-file-utils
depends = libevent
depends = qt5-base
depends = miniupnpc
+ depends = libminiupnpc.so
depends = qrencode
depends = protobuf
depends = zeromq
+ depends = db4.8
provides = theholyroger-qt
conflicts = theholyroger-qt
diff --git a/PKGBUILD b/PKGBUILD
index 5dd247be09c7..3d9ea6206dd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
pkgbase=roger-wallet-git
_gitname=TheHolyRogerCoin
pkgname=('theholyroger-daemon-git' 'theholyroger-cli-git' 'theholyroger-qt-git' 'theholyroger-tx-git')
-pkgver=0.16.3.rogerv3r+0+g4fee9e4
+pkgver=0.16.3.rogerv3r+2+g21d2fb2c7
pkgrel=1
pkgdesc="The Holy Roger Coin (ROGER), the leading altcoin derived from Litecoin. ROGER is developed with a focus on outing scams and trolling The Fake Roger."
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://theholyroger.com"
license=('MIT')
-depends=('qt4' 'miniupnpc' 'openssl' 'protobuf')
-makedepends=('pkg-config' 'boost-libs' 'boost' 'db4.8' 'gcc' 'gcc-libs' 'git' 'qrencode' 'make' 'automoc4' 'automake' 'autoconf' 'libtool' 'zeromq')
+makedepends=('boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq' 'db4.8')
provides=('roger-wallet' 'theholyroger' 'theholyroger-qt' 'theholyrogerd' 'theholyroger-cli' 'theholyroger-tx' 'theholyroger-daemon')
conflicts=('roger-wallet' 'theholyroger' 'theholyroger-qt' 'theholyrogerd' 'theholyroger-cli' 'theholyroger-tx' 'theholyroger-daemon')
source=(
@@ -34,14 +33,14 @@ pkgver() {
build() {
cd "$srcdir/$_gitname"
./autogen.sh
- ./configure
- make -j$(nproc)
+ ./configure --with-gui=qt5
+ make -j$(nproc)
}
package_theholyroger-qt-git() {
pkgdesc="The Holy Roger Coin (ROGER), the leading altcoin derived from Litecoin - Qt"
- depends=(boost-libs desktop-file-utils libevent qt5-base miniupnpc qrencode protobuf zeromq)
+ depends=(boost-libs libevent qt5-base miniupnpc libminiupnpc.so qrencode protobuf zeromq db4.8)
conflicts=(theholyroger-qt)
provides=(theholyroger-qt)
@@ -59,7 +58,7 @@ package_theholyroger-qt-git() {
package_theholyroger-daemon-git() {
pkgdesc="The Holy Roger Coin (ROGER), the leading altcoin derived from Litecoin - daemon"
- depends=(boost-libs libevent miniupnpc zeromq)
+ depends=(boost-libs libevent miniupnpc libminiupnpc.so zeromq)
conflicts=(theholyroger-daemon)
provides=(theholyroger-daemon)