summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Roest2020-11-28 19:55:08 +0100
committerVictor Roest2020-11-28 19:55:22 +0100
commit8f3991896a0b377802b7369b99732dcc94e5a44d (patch)
tree5d903c04a3ea8792ebd94bd4a623edca9b90f496
downloadaur-8f3991896a0b377802b7369b99732dcc94e5a44d.tar.gz
v0.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba76dfbd2e1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = roll-rs
+ pkgdesc = A rust dice rolling application using the standard dice notation
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/finitum/roll-rs
+ arch = x86_64
+ license = EUPL-1.2
+ makedepends = cargo
+ provides = roll-rs
+ conflicts = dice-roller-git
+ conflicts = roll-rs-git
+ source = roll-rs-0.1.0.tar.gz::https://github.com/finitum/roll-rs/archive/0.1.0.tar.gz
+ sha512sums = e09d527c522e834110f901a5ba9bbe2bcbefdda5eb1f6e9c28bfc02a407a8026a5efd6ef885dfd75a96558eab9dc5f04bd8ab6f468c7427cada2622f93871427
+
+pkgname = roll-rs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce0f1dc0319a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Victor Roest <victor at xirion dot net>
+# Co-Maintainer: Jonathan Dönszelmann <jonabent at gmail dot com>
+pkgname=roll-rs
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A rust dice rolling application using the standard dice notation"
+arch=('x86_64')
+url="https://github.com/finitum/roll-rs"
+license=('EUPL-1.2')
+conflicts=('dice-roller-git' 'roll-rs-git')
+provides=('roll-rs')
+
+makedepends=("cargo")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/finitum/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('e09d527c522e834110f901a5ba9bbe2bcbefdda5eb1f6e9c28bfc02a407a8026a5efd6ef885dfd75a96558eab9dc5f04bd8ab6f468c7427cada2622f93871427')
+
+build () {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+check () {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked --target-dir=target
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/roll" -t "${pkgdir}/usr/bin/"
+}
+