summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenny Stier2022-06-21 11:32:13 -0400
committerKenny Stier2022-06-21 11:32:13 -0400
commit71f6e6b92d70ee627337b2cd5429f115b4db14c6 (patch)
tree9079cf1e7842b7cf3827a6427ec29e4214cd86d6
downloadaur-71f6e6b92d70ee627337b2cd5429f115b4db14c6.tar.gz
Create Rollo driver package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b789371ac171
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = rollo-printer
+ pkgdesc = Rollo (Beeprt BY-242) USB Printer Driver for Linux
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.rollo.com/driver-linux/
+ arch = x86_64
+ license = custom
+ depends = cups
+ source = https://www.rollo.com/driver-dl/beta/rollo-driver-ubuntu_x86_64_v1.0.2.tar.gz
+ sha512sums = e3d382bf0dd6d08ebb023b7270e50f09a09021c78bf387e9a1e172e5f965e3b53dc6e9144cd18b8d91024faa62390a609dbcfe506d11cb4a9308688342d53fb3
+
+pkgname = rollo-printer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4544d7d59fce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kenneth Stier <kenny at millhousen dot tech>
+
+pkgname=rollo-printer
+pkgver=1.0
+pkgrel=1
+pkgdesc='Rollo (Beeprt BY-242) USB Printer Driver for Linux'
+arch=('x86_64')
+url='https://www.rollo.com/driver-linux/'
+license=('custom')
+depends=('cups')
+source=('https://www.rollo.com/driver-dl/beta/rollo-driver-ubuntu_x86_64_v1.0.2.tar.gz')
+sha512sums=('e3d382bf0dd6d08ebb023b7270e50f09a09021c78bf387e9a1e172e5f965e3b53dc6e9144cd18b8d91024faa62390a609dbcfe506d11cb4a9308688342d53fb3')
+
+
+package() {
+
+ # install filter
+ mkdir -p "${pkgdir}"/usr/lib/cups/filter
+ install -m755 "${srcdir}"/rollo-driver-ubuntu_x86_64_v1.0.2/ubuntu_x86_64_v1.0.2/rastertolabelbeeprt "${pkgdir}"/usr/lib/cups/filter
+
+ # install ppd
+ mkdir -p "${pkgdir}"/usr/share/cups/model/beeprt
+ install -m644 "${srcdir}"/rollo-driver-ubuntu_x86_64_v1.0.2/ubuntu_x86_64_v1.0.2/ppd/ThermalPrinter.ppd "${pkgdir}"/usr/share/cups/model/beeprt
+
+}