summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Hague2015-09-27 12:35:14 +0100
committerMatthew Hague2015-09-27 12:35:14 +0100
commit8cb3151ce97a4a2403f13e510c242dc742fefa15 (patch)
treec38163db2aebe34231b1cd1268a481404e5f9ec0
downloadaur-8cb3151ce97a4a2403f13e510c242dc742fefa15.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b27745731b64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rolo-git
+ pkgdesc = Tracks your contacts with vCards and displays them to you with a text-based menu.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/yourealwaysbe/rolo
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ depends = ncurses
+ depends = libvc-git
+ source = git://github.com/yourealwaysbe/rolo.git
+ md5sums = SKIP
+
+pkgname = rolo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39ae52a7c17f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Matthew Hague <matthewhague@zoho.com>
+# Maintainer: Loui Chang <base64:bG91aXBjLmlzdEBnbWFpbC5jb20=>
+# Contributor: Matthias Hueser <mail at mhueser dot de>
+# Contributor: Daniel Griffiths <ghost1227 at archlinux dot us>
+
+pkgname=rolo-git
+pkgver=1
+pkgrel=1
+pkgdesc="Tracks your contacts with vCards and displays them to you with
+ a text-based menu."
+arch=('i686' 'x86_64')
+url="https://github.com/yourealwaysbe/rolo"
+license=('GPL')
+depends=('ncurses' 'libvc-git')
+makedepends=('autoconf')
+conflicts=(rolo)
+provides=(rolo)
+source=(git://github.com/yourealwaysbe/rolo.git)
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/rolo
+ autoreconf -f -i
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd $srcdir/rolo
+ make DESTDIR="$pkgdir" install
+}
+