summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-07-12 19:59:59 -0400
committerDarvin Delgado2023-07-12 19:59:59 -0400
commitef54f06d491087c55977ec466b569e3138029f53 (patch)
tree17c64a6833330e5e80d6f4df4f032e9dd8cb3b29
parent733cc9806615cd34b58176a1a845ac05f28961d0 (diff)
downloadaur-rom-properties.tar.gz
v2.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c80dbc7f413a..be637435e094 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rom-properties
- pkgdesc = This shell extension adds a few nice features to file browsers for managing video game ROM and disc images
- pkgver = 2.1
+ pkgdesc = This shell extension adds a few nice features to file browsers for managing video game ROM and disc images.
+ pkgver = 2.2
pkgrel = 1
url = https://github.com/GerbilSoft/rom-properties
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = rom-properties
optdepends = zstd
optdepends = lz4
optdepends = lzo
- source = rom-properties-2.1.tar.gz::https://github.com/GerbilSoft/rom-properties/archive/v2.1.tar.gz
- sha256sums = 0322ade297b0b04196741da8b87e9b12d06ab58dbca8f0fef5fc3da1754f7904
+ source = rom-properties-2.2.tar.gz::https://github.com/GerbilSoft/rom-properties/archive/v2.2.tar.gz
+ sha256sums = eef7f41036124ea49ddd59f2460808c25537b9e8ba96f70ac75ebc39014c8232
pkgname = rom-properties
diff --git a/PKGBUILD b/PKGBUILD
index c5db295252e1..8420995272a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
pkgname=rom-properties
-pkgver=2.1
+pkgver=2.2
pkgrel=1
-pkgdesc='This shell extension adds a few nice features to file browsers for managing video game ROM and disc images'
+pkgdesc='This shell extension adds a few nice features to file browsers for managing video game ROM and disc images.'
arch=('x86_64')
url='https://github.com/GerbilSoft/rom-properties'
license=('GPL2')
depends=('curl' 'zlib' 'libpng' 'libjpeg-turbo' 'nettle' 'tinyxml2' 'libseccomp')
optdepends=('zstd' 'lz4' 'lzo')
makedepends=('cmake' 'pkgconf' 'gettext')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/GerbilSoft/rom-properties/archive/v${pkgver}.tar.gz")
-sha256sums=('0322ade297b0b04196741da8b87e9b12d06ab58dbca8f0fef5fc3da1754f7904')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/GerbilSoft/rom-properties/archive/v$pkgver.tar.gz")
+sha256sums=('eef7f41036124ea49ddd59f2460808c25537b9e8ba96f70ac75ebc39014c8232')
build() {
- cd "${pkgname}-${pkgver}"
- rm -rf build
- mkdir build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cd "$pkgname-$pkgver"
+
+ mkdir -p build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=lib/$pkgname -DCMAKE_BUILD_TYPE=Release -DSPLIT_DEBUG=OFF
+ make
}
package() {
- cd "${pkgname}-${pkgver}/build"
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname-$pkgver/build"
+
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: